SN3 Balance via remote not working

Just noticed I can’t adjust the balance on my SN3 via the narcom remote, everything else seems to work on the remote except the balance, I’ve tried powering down the amp, changing remote batteries etc but no joy, anyone got any ideas?

Press the ‘pre’ button. I claim my £5.

No cigar I’m afraid, tried that, remember the vol works fine

That’s a shame. Presumably it’s worked before? If so, it may be a dealer issue, as you have done all the obvious tests.

Try easing the balance knob back from the facia plate a touch. It may have gotten pushed on too far. This worked on my old nac 102 years back.

Yes it definitely worked before, I wonder if it’s the remote or the amp? Unfortunately yet another issue on a very long list of problems I’ve had with Naim equipment to date. I’ll fiddle around a bit more.

Yikes! I know it works on the olives but I wouldn’t do that on a new SN3. It might break something.


Seems to be a fault alright, I’ve tried everything. I suspect the amp rather then the remote. I’ll see if I can get hold of another remote to rule that out and failing that it’s back in the box unfortunately, I’ll speak to my dealer but I’m actually tempted to chop in the SN3 & NDX2 in at this stage and look at alternatives. It’s not that the balance not working via the remote is a big deal but yet another fault is extremely irritating.

What’s the other fault?

Started out with a faulty Muso, chopped that in for an Atom after a few months, to be fair I’m not sure the atom was actually faulty but it never sounded right and seemed to sound quite different with each firmware upgrade, got fed up and chopped that in for a Nova, the 3rd Nova was fine! Chopped the Nova in for an SN3 & NDX2, first SN3 had dreadful hum and got returned, still waiting out for the screen freeze / reboot fix on the NDX2

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.