Software bug in Uniti Core?

I use the Core to stream music to the Atom by wifi and everything works fine. I use the Core to stream music to my MacBook Pro (using mconnect on the MacBook) which is connected by USB to a DAC which drives a headphone amp to my headphones. And everything works fine. Then I though of trying to connect the Core directly to the DAC using the Core coaxial output to the DAC coaxial input. At first everything seemed fine, but then if I was switching albums the Core stopped playing altogether. The track would come up on the app just fine, but refused to play. Going back to the Mac and usb worked fine, Atom fine, but going back to the coax and the Core was locked up. Nothing I could try would get it out of this lockup unless I did a full shutdown (hold the button for several seconds, hear the relay switch over) of the Core, then it would work into the coax just fine for a while, changing albums etc, until it locked up again.

Looks very much like a software bug to me, but perhaps not too many people trip over it as it seems to only happen with the coax output.

Has anyone else found this?

That’s not a full shut down of the Core. It just puts it into “Deep Sleep”.

I suggest you do a proper full shut down and restart which is that after putting it into deep sleep, disconnect the power to the Core for say a minute so that everything in it is unpowered and then plug the power in again. It will restart.

If that doesn’t fix your problem, then turn everything off properly again, but this time restart your router and when it has fully restarted, turn everything else on again.

Thanks for your response. I’ll give that a try and report what happens.

Unfortunately that didn’t do it. It seemed to be working well for a bit and then no tracks would play. The app seems to be doing its thing, selecting albums etc. but touching ‘play’ has no effect. I have a different problem that may or may not be connected: I keep getting an app message saying “Streamer not responding” and the core room would disappear from the app, only to reappear in a minute or two. Once it reappeared everything worked fine – until it didn’t. This with me sitting only a few feet from the router. When I use the Atom to play music, from Tidal or Core, I get the same message “Streamer not responding” and this time the Atom room disappears and then comes back. I may have a poor router, so I will be thinking of replacing that sometime soon. All somewhat annoying, but it’s not as if I can’t get music to play.

For the sake of testing if you are only a few feet from the router hook up an ethernet cable to the core and the atom and see what happens?

The Core has to have Ethernet as it doesn’t have any WiFi. But a direct cable from Core to router with no power line adapters or whatever would be good.

You need to shut the core down as per the shutdown proceedure in the manual.

Press and hold standby button for 3 seconds. You will hear a click. Core is now in deep sleep.

To reset to factory settings: Unplug power cable. Wait 2 or 3 minutes. Press and hold down standby button, Re-insert power cable into Core mains socket and wait for Naim Logo and Front USB LED will begin to flash several times… allow to flash 3 or 4 times, Then release STANDBY BUTTON.

The core will revert to FACTORY DEFAULT SETTINGS.

You then need to reconfigure Work Group, Music Stores and Music Shares where and when necessary.

If you have have files on the internal Hard Drive they will still be there. You will be given the option to save or delete them in Music Stores Settings.

The Core is a very FINE RIPPER/SERVER.

Suggest you reboot your Router first then Factory Default Reset

Reboot Router, wait for it to boot up.
Reboot Streamer…Sound as is you are having comms dropouts from device you have the Naim App loaded on. Affecting the WI-FI comms link between your tablet and your streamer.

Personally I wouldn’t do a factory reset of the Core unless I was really sure that everything in my network was definitely right. It’s kind of a last resort.