Software update issues

Hope that anybody can help me with this.
Trying to get an software update on ND5-xs. It was 4.4, so two updates to go.
Brought the streamer to my study to connect with the iMac. Wired both through ethernet on DecoM9 mesh. And USB to USB-min between streamer and iMac.

  1. the Mac doesn’t recognise usb bus, it only gives possibility to “Bluetooth Incoming Port”. No communication?
  2. Checked the drivers on the iMac, that seems to be ok
  3. checked al the cables, replaced them, try again
  4. then the Mac doesn’t detect the streamer. Switching on/off doesn’t help
  5. after a couple of times the streamer itself ‘disappears’. Meaning, neither the app on the iPhone nor the DecoM9 shows it as online but offline
  6. but at the same time it does connect through UPNP with the music library on the mac

Repeat and repeat from the start, by the book - doesn’t work

so what could be going on?
Anybody any idea?



You can go straight from 4.4 to 4.7. No need to go through 4.6 in between.

You have to make sure that the USB lead supports data and isn’t just intended for battery charging. The latter sort don’t have the data pins connected.

And you have to install the right drivers to your Mac. The firmware update notes explain what you need to do.



Hi David

Thx. Thought I had to update one by one.

Tried all the USB ports on the back of the iMac (they all normally support data)
And checked the drivers as well. Same as required.

Don’t get it.

But maybe i I try to install the latest 4.7 instead of 4.6?


David meant the actual USB lead may be power only - I always mix my leads up and some which are used to power/charge things over USB won’t transmit data as the relevant pins aren’t connected in the lead.

Yes it’s as Alley_Cat says. It’s the lead I am talking about.

You don’t need to do the updates sequentially on the old streamers. 4.7 can go straight on top of anything above 3.0 actually.

But do look at the firmware updating instructions because you need to download a special driver to your Mac first.


Ah, ok.
This lead is ‘borrowed’ from a camera (to upload photo’s).
I will look if there’s another, as updating from 4.7 gives sames problems.

And then: why stopped nd5-xs suddenly it’s WiFi connection to the app?!

There is no functional difference between 4.6 and 4.7 - either should work.

If you plug in an ethernet cable to the ND5 XS, it disables the wifi in the ND5 XS.

If the lead was borrowed from a camera for uploading duties, it should be ok.

What about the driver?



Hi David
Thx for your time, first of all.
Driver specs on the iMac are the ones required by Naim.
Tried a (newer) macbook as well. Same result.
Don’t know whats going on, don’t get why the nd5 doesn’t connect with the app anymore.
When it starts up now, it goes in a wink straight to ‘source’ instead of slowly starting up and checking network - like it always did.
I did then give the network-password again, but that doesn’t change anything.

I’m done with it for now. No update and no streamer connection; what a fruitful day!
Hope you all have better holiday experiences.



I don’t use Mac myself so I will have to let others advise.

Regarding the ND5 XS not appearing on the network, first of all I assume you usually use WiFi? So ensure that you have disconnected any ethernet cable connecting to the ND5 XS and then turn the ND5 XS off and then in again. You could check that WiFi isn’t still disabled using the remote. You press the spanner or wrench key on the remote and then navigate to the network settings. Make sure WiFi is on. And then back out again.

In your phone, if you stop the Naim app by swiping it off upwards from the app selector menu, then restart it, it should look again for your rooms. Hopefully it will now find the ND5.



Have you actually installed, per Naim’s instructions, the UART drivers on your Mac? (I don’t have it with me, but I think it’s something like “USB to UART” drivers. In any event, the documentation with the Naim install package tell you just what they are.)

If you haven’t, it “ain’t gonna work.”

It happened before!

Pretty well everything has happened before!

Anyway I hope it will work for you now.



I recall that a couple of years ago, a number of people experienced problems with the driver, and were apparently downloading the incorrect version due to a problem identifying the correct version. Never had the problem myself, but possibly something to be aware of.

AND I recall an issue . . . vaguely . . . where the proper driver (UART) doesn’t show up in the pull-down list unless the Mac is first connected to the ND player. Which might be contrary to the instructions. Vague vague memory about this.

@Arno This might be a silly suggestion but the first time that I tried to update my 272 I plugged the the usb lead into the wrong usb socket on the streamer. I should have connected it to the mini usb on the rear of the 272 and not the standard size usb socket on the front. Not sure if your streamer is the same.

Yes, finally!

It was indeed the wrong usb driver. I had to reinstall it and ‘allow’ acces for it.
For one reason or another some Macs give that issue.
So @Bart, your memory was not vague but accurate. Like @CrhrisSU said.

Thx for all the support to you all!!


Glad to hear you got there in the end!

You’re welcome. One of the best parts of this forum; people helping people. Cheers and happy new year!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.