Sonore UPNP Bridge for Roon on NDS - Help!

Hi to all, having read most of the forum entries on Roonification of legacy streamers, I am trying a Sonore UPNP bridge from SGC for my NDS. No problem with basic setup, software updates, discovery etc. The issue is tracks skipping (the whole time, not just occasionally). I have tried to isolate a few things and I think the issue is anything over 44.1kHz red book. So any 24/96 or higher from my own library and anything from Tidal Masters. Once the skipping starts I have also had it happen to red book files as well. I’m not overloading it by rapid button presses or lots of DSP - as soon as I try hi-res, skipping starts immediately. I can get anything from continuous skipping through tracks on the playlist, up to about 30 seconds of playback before it skips.

Roon works perfectly on my other endpoints up to 24/96 so I don’t think it is a Core issue. Set up as follows:

Netgear unmanaged switch connected to:
Win 10 PC running Roon core
Sonore bridge
QNAP NAS for local files

Cat 5 running underfloor to Music Room:

Cisco 2960 switch:
Naim NDS

Bridge settings used: Max sample rates tried from None right up to 384kHz and Format both WAV & LPCM (I found LPCM was just delivering noise, although in your documentation it does indicate this should work with Naims 1st generation streamers). I will add that I have not tried any DSD files, just working with FLAC for now.

To isolate the issue I have also configured the Bridge to send the stream to my Kitchen MUSO (thus taking the CISCO 2960 and NDS out of the equation). Exactly the same behaviour.

Also re-starting Bridge and / or Roon in between trying every variable seems to make no difference.

Finally I have focussed on Roon settings – it seems that in the advanced device settings for a Squeezebox device, Roon offers me 3 choices 48/96/192kHz max. With 96 and 192 it will skip every time. Only when I set it to max 48 does the skipping stop. I found that at 48kHz, I can make changes in Roon like adding DSP without needing to restart anything, but as soon as I go to a higher sample rate, it doesn’t work. Have also tried with FLAC compression ticked and unticked. I will add that I pause playback in between any of these changes, I’m not trying to stress test the bridge.

I’m fast running out of ideas, but I think there are many satisfied Naim users out there, any thoughts would be appreciated!

Hi there,

Not sure how much help I can be here, but I am running Roon to my NDS using the Sonore UPnP bridge.

My Core is setup on a NUC running Roon ROCK. Same as you, I am running a wired connection the whole way.

I have no issues playing 24/192 local files or via Tidal.

I did have an issue similar to you when I was trying Roon using a Win 10 PC and a Google Chromecast Audio. I put that down to the wireless connection as I had similar issues trying to use the NDS wirelessly.

If there is particular setting you want me to look at, let me know.

Good luck.

Have a similar configuration, i.e. NAS, Roon Core, Sonore UPnP Bridge to NDS.
However, my instance of the Sonore UPnP Bridge is run on the network segment with the NDS and not the NAS/Roon Core segment.
So could you try moving the UPnP Bridge to run off the Cisco 2960.
My settings on the Bridge are: WAV output, with no sample limit and DoP for DSD support.
In Roon Core, however, I set the max supported sample frequency to 192KHz and FLAC compression Off.
Also you could try putting some local music on the Roon Core device, and moving this to the Cisco 2960 segment also, so eliminating the connection between your Office and Music Room.
Also is the Cisco 2960 running in any advanced managed configuration, re. Multicast discovery, IGMP snooping etc. Is there a way you can run this switch in ‘unmanaged’ mode? Once you have the Core and the Bridge on the Music Room segment, you may want to swap the Cisco 2960 for the Netgear (just to eliminate possible causes).

If you could monitor the buffer on the NDS also - it the track dropping out as the buffer is exhausted?
What version of SonicOrbiter is the Bridge running, and what is the version of the UPnP Bridge, as I had issues with an earlier SonicOrbiterSE unit running SonicOrbiter 2.3. I am now running an UltraRendu with SonicOrbiter 2.7


Sounds like this could be a network issue or your core is choking on something. I take it your Roon core and Sonic Orbiter are all hardwired to the same network? Have you checked in Roon 's signal path to see if there is anything going on that’s obvious like a low processing speed? If the core is not being able to keep up then this can have some effects on playback. Under normal conditions you normally would not see any processing speed.

Thanks to all for your detailed comments, appreciated. I’ll have a play with some network variables tonight, will keep you posted.

I have had a similar issue but it was before I started using Roon so I must conclude that it is not Roon,

Using the Naim app and my NDS which is connected by ethernet via a Netgear switch to my Synology NAS running Minim server.

What I have found is that when I change from a Redbook file to a Hi Res it stops playing and skips every track I select as if it cannot find it, even if I go back to the track I have just played. If I wait 5 mins or so everything works perfectly.

So this seems like an NDS or network issue to me. Any ideas?

I need to add to this that it is the same for Tidal tracks, not just from my NAS. So it must be either the router, the switch or the NDS? Any one with any suggestions?

It just happened as I was writing this. I restarted the router and all was fine…

The router is an Asus RT-AC87U it seems this is the culprit…any ideas of what setting I may have missed?

Interesting, I have tried to apply some scientific rigour to this, making one change at a time, and also by monitoring the server behaviour using Task Manager. Roon seems to be running well within the comfort zone of my PC, with or without DSP applied. But I was having a continuous skipping sequence with any hi -res (i.e. no music at all). In these cases the Sonore device web app showed that it was losing contact with the NDS (with Roon still apparently connected). I also found that even red book could skip after playing for a while, playing to about 60-70% then skip to next track. It seemed like a general buffering problem which is exacerbated by 24/192 files.

Right now I have local and NAS files playing OK up to 24/192. It seems stable so far.

This was achieved by connecting the cisco switch (for NDS in music room) directly with Cat 6 to the BT router (in office). I also attached my server (win 10 PC) and the Sonore device directly to the router. I re-purposed the Netgear switch for all other domestic connections, including the NAS.

So, we seem to be getting somewhere, however if I queue up a pure Tidal playlist, some files will play 100%, some 10% or more before eventually skipping to next track. Again this is irrespective of red book or 96kHz Tidal Masters.

Anyone think this could be down to router settings? If find it odd, since I can routinely watch hi-res video over Netflix, piped to my lounge via an ancient Devolo powerline system.

Thanks for reply Simon, I will add that I am running SonicOrbiter 2.7 and have the latest update of the bridge app. You mention the buffer on NDS - how do you go about monitoring this?

I have also tried the Sonore and the server on the Cisco in music room to eliminate the office segment. Again, the breakthrough seemed to be direct connection of server and Cisco switch to the router.

David, your skipping behaviour does sound familiar. My NDS has been running flawlessly for years via Asset / Nas with all files. Same with Tidal via the Naim app. So I am only having problems since introducing Roon. I guess the answer lies somewhere in the network configuration?

The NDS buffer is visible via the front screen under one of the display options.
Have you tried moving the Sonore bridge to the Cisco, then the Roon Core, just leaving the NAS on a remote network segment?
Also confirm with local track on the PC running Roon Core, i.e. a local network segment with the NDS

For me this was happeneing before Roon or Sonore Bridge. The NDS message was cannot find track or words to that effect

Simon, on display setting on my NDS I can only set the display off delay, no options to show a buffer. Are you in service mode or do I miss something else? I have latest firmware. Thanks.

From the User Manual
Buffer is part of the ‘data stream info’

Thanks Simon, funny I have never even been aware of the display options since my NDS is kept hidden from view and I only ever use the ipad for control… Anyway, this helped me to understand that the buffer is filling up as expected and quickly empties when Roon has a problem. I don’t think there is an issue there. I tried my Pc running Roon with local music on SSD straight into the local CISCO in Music room, same issues.

Then I simplified things by just running a Mojo directly from my PC connected directly to the router, no switches or NDS or bridge. I was able to replicate dropouts, most effectively using Tidal MQA and adding some DSP. I found that with a processing speed as low as x2-x4, I could replicate dropouts / skipping, usually in between tracks as Ron looks to prepare the next file. I think any delay here causes the DAC to run down its buffer and then Roon skips to next track to try and recover things. Using the internet would stress Roon also. I then realised Roon uses the graphics card for its display - Task manager indicated some high power usage associated with that. Even though Roon does not appear to be stressing the PC (about 10% of overall CPU and 1GB of Ram), I understand that it will use a single core per endpoint. My PC is an older Core I7 running at 2.4gHz. With all this in mind, I installed Roon server only and used ipad for control. This means no load on the GUI and only half the RAM utilised - somehow this seems to have improved matters - typically I could play 5-6 consecutive tracks of Tidal MQA before getting a dropout in between tracks - then it will play from the next track without my intervention.

Now I can stream to the Sonore bridge in the music room via the CISCO and only get dropouts when I purposely stress the system, fast forwarding multiple tracks on a playlist, heavy DSP etc. So not perfect but at least basically usable as proof of concept within my system.

So I think a dedicated Roon Rock core using a new i7 NUC at 3.5gHz will probably solve my issues. For all the world I wanted to blame the Sonore device, but now I think it is doing its job. Which is quite valuable when the alternative is a new ND555!

Thanks to all for comments, I hope this feedback could be useful for others.

1 Like

Glad you seem to have got to the bottom of the issue.

Yes, the ability to ‘Roonify’ the NDS without the huge expensive of an upgrade to the ND555 or introduce format conversion to S/PDIF is of particular value. The SQ the NDS delivers is excellent, and with the convenience of Roon, the UI/UX is great.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.