Spotify not working on uniti Nova

Fellow music fans… I am at my wits end.

Suddenly, with no warning, my android phone Spotify app will not connect to my Nova. By this I mean that I can no longer select it from the list of available device.

I have checked the firmware level on the app, router and Nova. Rebooted everything a dozen times. I know that my phone and nova are on the same network. I can select internet radio stations and other sources from within the Naim app. I can adjust the volume from the app. Everything else works.

But the Spotify app, when selected from the Naim app, does not show the Nova as available. Simply says ‘can’t play this right now’ under a faded Naim device logo.

When I go back to the Naim app, Spotify is not shown as selected. That’s odd. I selected it and opened up the Spotify app.

Likely something stupid from my side. Particularly as a search within the forum shows nobody else with this problem.

I have noticed that the whole setup process is not idiot proof. Maybe a limitation of the technology, but it might be worth having the developers look at making things more robust.

Does any have any ideas?

Soon to be BALD… Regards, Thomas

Hi @ThomasD

What happens when you go to the Naim app, click on the Spotify logo in the Naim app?

I wonder if you need to log in to Spotify in Naim app. When i touch the Spotify logo in the Naim app, it gives me 3 options…Resume Playback, Open Spotify and Help. I know to use Tidal in the Naim app you need to log-in in the Naim app. Can’t remember if you need to do the same for Spotify. Or does Spotify start to play if you press Resume Playback. Not sure if this will help but an option. I assume this is one of those glitches.

All the best with figuring this out.

Thanks Sven for coming back to me so quickly.

When I select the Spotify logo I receive the options to either open the Spotify app or select Help. I do not get “resume playback”. The help option isn’t… Helpful, I mean.

@ThomasD have you tried pressing the Open Spotify?

I just checked and Resume Playback comes up on my iPad but not on my Samsung so perhaps that features is iOS only.

Hi, this is just a guess, but I wonder if your Nova has been allocated a new IP address, and Sootify has failed to pick this up. You could try signing out of the Spotify app and signing back in, or even deleting and reinstalling the app, then search for it again from the Naim app.
Just to be clear, are you usung Spotify Connect, or are you using Chromecast?

1 Like

Brilliant! It worked. I think I wanted to avoid trying this as I would have to find my password again and it would loose all my offline files.

I cannot see why this would make a difference. The IP address should be passed to the Spotify app via the login account. I guess this is some sort of bug. Probably in the Spotify app as it should be able to interrogate the account details and connections saved within the account.

Or maybe the Nova is not keeping/updating its connection details correctly.

Who knows. Well, at least it now works.

Thank you Chris. Enjoy your weekend!

1 Like

Good to hear you’re sorted. :slightly_smiling_face:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.