Static purple light on streamer ND5 X2

Since moving house and having a new modum my streamer just displays a static purple light. I have tried holding the power button and pulling the plug, replacing it etc but to no success.

I’m not a particularly tech person so It is a bit of a mystery to me.

Any suggestions.

Purple LED = Wireless connection configured but network not found.

Try this link it has some nice info. Click on Support, it has some nicely laid out troubleshooting advice.


Yes basically you need to tell your ND5 XS2 about your new WiFi. The purple light just means it is looking for your old WiFi and not finding it.


That is hugely appreciated. Will follow the :pray: :pray: link.

1 Like

So with that in mind do I

  1. Restore factory settings.
  2. Set up wi fi using Naim app.

On the restore factory setting can you use a straightened paper clip to depress the button?

Thanks in advance

Is there any way you could temporarily connect it with an ethernet cable? You could then use the built in web interface to configure the new WiFi details.

That shouldn’t be to hard.

So in reference to this matter. I have done the ethernet cable and it worked perfectly. I then tried to reconfigure to wi fi but still ended up with a static purple light. I have reset the streamer with help from the local supplier.My question is ; does the streamer search for the previous wi fi network and not see other networks. I am in a new house with a completely new network and modum etc.

Thanks in advance.

if you did factory reset then its as though its new and will only pick up what it can see locally…

1 Like

I’ve had issues in the past with various Naim streamers that seem to hold onto previous network settings and not allow a new network to replace them, even after a factory reset.
The last time this happened was with a Muso, and after the factory reset I went through the setup routine about 10 times before it eventually worked. The indicator light was varously pruple, green, and sometimes a funny yellow colour that isn’t even on Naim’s list of colours.
Persistence seems to be the only way.

1 Like


That would appear to be true. Attempt no.5 happening now.

I’m very happy to say that the issue has been resolved. Took a bunch of attempts but finally i got the breakthrough. Not sure what changed but happy to have sound again.

Thanks for all the input.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.