StreamerUpdate 4.8

I need to update my Uniti Lite to Firmware 4.8 as TIDAL is no longer working. I followed all the instructions but i cannot find the Naim Streamer Software.

Under www.naimaudio.com/updates, only the 4.7 version is available. Where can i find 4.8?

The reason you can’t find not is that it’s not yet available. However, you shouldn’t have to wait very long…

Ok thank you. I am looking forward to that because I cannot use TIDAL since last week. I hope it comes in the coming days.

It should release tomorrow - as ever, we’ll put all the info up here, plus send out by email, and have detalis on the Naim website.

Our retailer network also has all the information and is ready to assist as needed.

Hi i am trying to install the streamerUpdate 4.8 but when i try to open the downloaded software it says" Naim Streamer Updater can’t be opened because Apple cannot check it for malicious software". The software needs to be updated. Contact the developed for more information.

What shall i do?

This is covered in the instruction guide - you need to check the security settings in MacOS, which default to only allowing downloads from Apple App store

1 Like

Not 4.7.1? This includes new features?

If you did the 4.7.1 update yourself then maybe you still have the file. Otherwise you will have to persuade Naim support to send it to you I think.

Getting error message on PC download; “file blocked because it could harm your device”. Tried turning off Windows defender and no joy. Solution not mentioned in the guide.
Any ideas?
Thanks

You may need to accept files from Naim or similar. But I don’t know Windows Defender. Norton Internet Security on my old Windows 7 pc did a lot of blustering but ultimately let me make the decisions.

@Schloss1 this happened to me. Assuming you are using Catalina, latest version update was today by-the-way. You can hover over the Naim disc image right click and manually select ‘open’ and then override the security notification. This should work.
Let us know how you get on.

1 Like

That’s a Defender problem really, and resolution details probably depend on version, etc. Is there no button in the message to override it?

It’s also a common problem with all kinds of software, and at my workplace, a software developer, we fought Microsoft for months about this, because users got the warning although our software is perfectly legitimate and fulfilled all of Microsoft’s requirements. Unfortunately, Defender decides this not just based on rules but also based on heuristics such as “how often did Edge users download this file”, meaning that whenever we released a new version, Edge tried to block our customers from downloading it!

You may have luck with this:

or other guides that you will find if you google for the exact message text

Got it working in the end using a different laptop.
Very hit and miss with the USB-b cable. First one wouldn’t work but another one did.
Anyway all good. Thanks everyone for their input.

1 Like

Some USB cables that people may have lying around are dc only cables, intended for battery charging purposes. But to do this update you need the data connections to be there too. Of three cables I found in my old cable box, only one worked for this application.

Anyway I’m glad you sorted it in the end.

@Suedkiez thanks for referring me to this thread, I managed it simply by clicking the box which blocks it and right clicking and choosing keep

1 Like

The message is not making it very obvious if I remember correctly :slight_smile: Good luck with the rest!

1 Like

I’d like to update my 272 to the the new 4.8 streamer version but reading the update instructions carefully I noticed I need to be running macOS 10.15 Catalina or later, which sadly I’m not as I’m still on 10.13 High Sierra for software compatibility reasons awaiting the eventually launch of the updated Apple silicon Macbook Pros (which is a bit like waiting for an updated 272 :laughing:) followed by an update to some older software.

I’ve installed the latest USB driver, the streamer updater software seems to run OK, tested up to the connection check stage without connecting to the 272.

Does anyone know if the update is possible on 10.13 High Sierra or is it a definite no? I appreciate the instructions would indicate a no but I’m looking to see if there’s any further information on the compatibility? I wont proceed unless there’s some further information to the good.
Thanks!

The instructions only indicate what Naim tested it with. Not what won’t work.

I bet Naim didn’t test it with Windows 7, but I know it works just fine.

I think you will be fine with High Sierra, but I haven’t tested it either, just like Naim.

Best

David

2 Likes

I’m running MacOS 10.11 El Capitan .
Two year’s ago , no problem with the last Update 4.7 ( on my Superuniti )
Now I can’t recover the 4.8 Installer . ( l can’t open the disk Image )
It would be nice if we could recover the 4.8 installer as easily as the 4.7 !

It’s not a disc image. It’s just an executable file, exactly like the 4.7 update. You should have no problem executing it. You just download it to your mac and run it. It installs itself and off you go…

The disc image business was only with Unitiserve etc….