Successfully ripped CDs not showing up in Uniti Core Albums list

Two albums I successfully ripped using my new Uniti Core appeared immediately, as expected, in the list of ’Newest Music’ and ‘Albums’ etc., but then a couple of days later they disappeared! When I searched for them they quite simply were not there. They were in no other folder (Albums with ripping errors, etc.) and the album total was correct without them. I have tried re-ripping them, seemingly successfully because I’ve followed the ripping process, but the Uniti Core still stubbornly refuses to show them. I’ve got round it by uploading them as WAV files on to Apple Music and playing them via my ND5 XS that way, but it’s still odd.

Never happened to me as I can remember.

I assume your Core has the last update, and fully rebooted as per discussions on this in past forum posts.

If it were me I might re-rip these cd’s and then immediately make them a “Favorite” (if only temporarily). Then play them, and see what happens to them from then on.

I’ve not heard of this problem before. I assume your internal HDD/SSD is showing properly as your Music Store in manage music?

I would do a power off restart of your Core and see if that brings them back. You could also try a factory reset, but that really is the last resort before you put the Core back in its box and take it back to the dealer for them to sort out with Naim.



Thanks, both, for taking the time to respond. The problem has not recurred with > 300 CDs I’ve ripped since, so I’m regarding it as a curio. I was unable to label the CDs in question as favourites, since they didn’t show up as ripped (despite the ripping process seemingly ticking all the boxes). The equipment seems to be working perfectly in all other regards and my supplier is a long way away. I’ll post again if anything further happens.

1 Like

Were you able to see the folders with the missing albums in when you connect to your Core’s drive from a computer? Also check the recycle bin to see if they’ve been moved there…

Thanks, JonoB. At the time I posted my query I was expecting the Naim app on my iPad or iPhone to show the relevant folders. I’ve now sussed out that it doesn’t do this and guess that I need to get n-Serve for Mac?

N-serve won’t work with UnitiCore. It’s intended for Unitiserve, HDX and NS0x servers.

You can see the folders in a UnitiCore with a Mac and indeed with an iPad, although it’s a bit of a faff with the iPad.

But if the rip has been put into a folder in Music/MQ then you mustn’t try to edit the metadata other than with the Naim app. It could help you identify where the rip has disappeared to though!



as Davidhendon points out, n-serve is for the older generation of servers (unitiserve). You’ll be able to browse to your Core from your Mac easily (go to your finder, connect to the server using command-k (or in the Go menu choose network), type in the IP address of your core using (in my case this looks like smb:// ), and press return. You’ll be shown a list of drives on the Core, and you can browse from there.

In the Store folder, you’ll an MQ folder, and under that a list of artists. You should (hopefully find the missing album in there).

If not, check in the recycle bin/deleted items.

As David pointed out, don’t try adjusting the metadata manually on the Core through your Mac - you should always use the Naim app to modify metadata.

Many thanks, both. On my MacBook Pro Finder > Locations > Uniticore gets me to the relevant folders. The missing albums (two of them) are not in the MQ folder, and if I search for key words (artist, album name) nothing comes up. On the other hand, all my other ripped CDs appear to be there. Nor do they appear to be in the recycle bin. It’s no biggie but I’ll keep an eye on things. I appreciate you taking the time to respond.

We all love a mystery!

What happens if you try to re-rip them? Does the Core just do it, or complain that they’re there already?

The Core wouldn’t complain. If you re-rip a CD that is already ripped, the Core just over-writes the existing rip when it’s finished ripping.

So not sure this is going to help unfortunately.

But it would appear there’s nothing there to overwrite. It would be worthwhile to see if it puts a copy in the expected folder this time around.

Yes it would be interesting to see that! My point really was that it won’t complain either way….

The Core happily re-rips the two CDs in question (it seems to find the correct metadata, and I can see it ticking each track as it goes along)—but then…neither is seemingly stored. I’ve just tried again with one of them to convince myself that what I am saying is correct. The ripped album neither appears on the app in ‘Newest Music’, nor does it come up when I search for it using key words, nor does it appear in the MQ folder. The two CDs are both the same label, but I’m not sure that’s anything to do with it because I’ve successfully ripped them to iTunes on my MacBook Pro, which is where they reside at the moment and are perfectly playable.

Any unusual characters in the Artist or Album Artist field? (Not sure how the Core builds up a folder structure.). Could be in the Album Title too?

Have you since ripped another CD successfully (to the right place)?

No and yes. No—there are no unusual characters anywhere. Yes—I’ve successfully ripped a couple of hundred other CDs to the right place.

You could put them into the downloads folder of the Core easily enough if you wanted to.

The other thing you could try is looking on the core (from your Mac) for files that are created on the day that you rip the albums. Maybe re-rip them before you try this.

You might find that the core is applying the wrong metadata to the albums (I’ve found this myself)

If nothing seems to work with these two albums, do you have ripping software on your Mac? If so you could rip them there and copy to the downloads folder on the core manually.

I do this with the albums I’ve got that the core can’t find metadata for.

Thanks again. I was just a step behind you. Copying the files from iTunes on my MacBook to the Downloads folder on the Core did indeed work except that the metadata isn’t there, and there seems not to be the option of finding the cover artwork etc. This may be an iTunes issue because, curiously, although the artwork and metadata for both ripped CDs shows up when I browse iTunes, and is present under ‘info’ for the albums, when I look in the folders on my MacBook the thumbnails for the files just show as skeleton icons (if that’s the right term), lacking the artwork. Anyway, I think I can live with what I’ve got and I don’t want this to necessarily run and run.