Suddenly can't access downloads folder through my Mac. Why not?

Sadly, for the first time in a long time, my setup is not allowing me to do what I need to do.My iPad and Core appear fine, and my Macbook Pro appears fine too. I have made no changes that I am aware of to any of them, but suddenly I can’t access the Core through my Mac. In the past, when I have wanted to drop folders containing music files directly into the Core’s Downloads folder, I have done it on the MacBook. Something is now preventing me doing that. If I open a new Finder window on the Macbook, as usual, scroll down the lefthand side to find my Core and click on it, normally that would have shown me the Music Folder and the Downloads folder on the Core’s SSD. But at the moment it doesn’t. It says ‘Connection Failed’ and if I click on ‘Connect As’, ‘Connection Failed’ changes to’No Connection’. Clearly I have upset a setting somewhere. I have tried powering off and on, and resetting everything: the app, and the Core, and the MacBook, and the network itself, to no avail. Help, please!

I am sure there was a very similar thread to this a few months ago, whereby access on the Mac was suddenly denied, but I can’t remember if it was resolved. Have you tried searching the forum ?

On Mac I think you can map to a server, I think it’s under the Go To heading in Finder. Not sure if this may help…


I have the same problem.
Like vintageaxeman resetting the network, Macbook, Core does not do anything.
In the six months or so that I’ve had the Core, I’ve only very briefly accessed the Core via my Macbook only twice. And briefly I mean that within the day itself I will find that the connection I had a few hours ago has been lost. I havent been able to access the Core since I managed to do it for a few hours a couple of months ago.
I think there is a defect with the Core. Just because others do not have this problem does not mean that it does not exist

1 Like

Can you scan your network to establish the IP address of your Core? (Fing is a free app for phones to do this)
It’s possible Finder has it on an old IP address which may have changed after rebooting the router (power cut?) even a replaced router.
Once you know the actual IP address of the Core, try opening a Finder window then clicking on “Go” then “Connect to Server” then enter the known correct IP address.

I posted a lengthy response to this 10 hours ago, somehow it has disappeared. Anyway, to summarize, I have had problems with my HDX folders and NAS backup folders not being accessible from my Mac. But in every instance simply doing a restart on the Mac solved the problem. Sounds like that is not working for you…

“Once you know the actual IP address of the Core, try opening a Finder window then clicking on “Go” then “Connect to Server” then enter the known correct IP address.”

I’ve done that. I know what the Core’s IP address is and it still didn’t work. Had message saying something along the lines of “no shares available.”

Hmmm, seems odd as I use a Mac and on the odd occasion I haven’t been able to access the HDX “Downloads” folder, connecting by the “Go” connect to server has always worked for me.
I’m running OS Catalina 10.15.1 if that helps you at all.

It can be a number of things, certainly macs have never been great with network sharing and the first thing I would try is force quitting the finder then trying again.

iNet Network Scanner is a nice app from the app store which will scan the network and restarting the core wont hurt.

Have you checked Preferences/Sharing/Media Sharing is ticked on?

As Gary says, finding a network drive on a Mac can be a bit pants at times, force restart Finder, otherwise a re-boot, should reset everything.

Yes, Blythe, I have done that to no avail…Using the Core’s network address, trying to connect via Finder…Go to … or Connect to… or Connect to Server…none seem to do it.And I have powered everything fuly off several times.

1 Like

Thanks, Mike_S, Settings/Sharing.Media Sharing was OFF. I turned it on but it doesn’t seem to have rectified the issue… I have never paid any attention to this setting, and to the best f my knowledge it has previously been OFF. Does it really need to be ON or is that making my MacBook unnecessarily vulnerable? Thank you.

I’m not entirely sure sorry, it may only relate to media on your Mac hard drive, or the Core as well?

When you powered off and on, did you include your internet modem?

1 Like

I have been following this with interest. I don’t use Mac so I asked a non-forum friend who has a Mac and a UnitiCore on the latest release firmware. He said he couldn’t see his Core downloads folder on his Mac, but he doesn’t use it much so hadn’t noticed before I asked. He has tried all the things Mike suggested and nothing helped.

My bet is that this is going to need a Core firmware change to fix it.



1 Like

SOLUTION!!! Mike_S. I just turned everything off including the Virgin Hub3, and the SSD in the Core now shows, but ONLY by me going to: Finder>Go>Connect to Server>Connect as Guest.
The actual CORE symbol is still not currently appearing in the main list of connected servers. But I have saved a couple of links to the DOWNLOADS folder and to see the MUSIC folder onto my desktop. Thank you!


Great! I forgot that I only log in as guest.

How does one connect to the Core with Windows? I borrowed a Windows 10 laptop but in File Explorer the Core shows up as a Media device, not a server. Prompts me to use Windows Media Player.
I’ve tried everything suggested in this thread but nothing works. I can connect to everything on the network without problem, including my old Unitiserve but not the Core.

For Windows 10 to access the Uniti Core you need to have SMB enabled on the PC.

There is an earlier thread on this:- “accessing-uniticore-downloads-folder“

Is there a way to set a static IP address for a Uniti Core, rather than it using the usual DHCP method? My network is based on a Virgin 3 box and, as I use Apple computers with OSX, an iPad etc., the Core is normally connected to an Airport Express.

This really shouldn’t be necessary. If your DHCP server is working as it should, there is no need. What you could try, though, is logging into your router, and allocating the Core an IP address from within the range of addresses it uses. Not quite the same a a static IP address, but easily done, and it may possibly help to keep it discoverable if it sometimes disappears.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.