Suddenly cover art not displayed on new rips on Uniticore

It was working until two days ago. Now all new rips to the Uniticore do not display cover art. When I use the Edit Metadata on the Naim App to change the cover, the cover is displayed on the App but only for around 30 seconds at most. And then it disappears.
When I look at the file folder via Finder on my Macbook, I can see that the file contains “coverfront.png” which I think is downloaded when the rip is done but also “userartwork.jpg” which may be the cover added when I used the Edit metadata function.
Any reason for this sudden change?
I have restarted both the Core and the App but that didn’t resolve the issue.
I have contacted Naim support but the email response said their response could be delayed.

Are you using the latest version of the IOS app? There was an issue a while back but it’s fixed in the current version of the app.



Yes. Version 5.21.1

I just changed the cover on a ripped album in my Core and it worked fine. Then I deleted the user-added cover in the metadata editing screen and saved and it worked fine. I haven’t seen any other reports of this issue and I pay particular attention to Core threads.

I don’t think the artwork names have altered at all. The other thing I would try after restarting the Core and restarting the app is to restart your router. You can get some odd things happen if your router has a service not working that the Core is using but your phone for example isn’t.

And another thing you could try would be to do a factory reset on your Core. (This doesn’t mess with your rips or downloads on the internal hard disc or network shares. But it will reindex the music which can take a while).



The problem isn’t being unable to add the cover art or change it. It’s just that after saving the change, the cover art is displayed on the App but then disappears after a few seconds.
I’ll try a factory reset tonight and let it reindex overnight.

Factory reset didn’t work. Still not showing the cover art.
But now, I see a list of Radio stations on the App that I’ve never seen before. If I tap on it and select play, nothing happens. Very strange. I use the Uniticore with the NDac and so no streamer.

Hmm. Did you try the router restart I mentioned?

Also have you looked at the userartwork.jpg and checked that the image is actually saved?

And if you use the app to look at one of the albums and then go to metadata editing, then forget user image edits and then change the image again, does it stay now?



Yes, restarted the router too.
The userartwork.jpg is saved. Tried the forget user edits and then changed cover again. After saving, the image does appear but as before only for a few seconds.

And the music store is an internal HDD/SSD rather than a NAS or other external store?

I’m struggling to think what this could be. If it were a general problem, we would see other reports here. And there haven’t been any so far as I know.

How did you do the factory reset of the Core?

If you play one of the albums with missing artwork, is it still missing from the Now Playing screen in the app?



Yes, ripped to internal Samsung 870 EVO drive.
Factory reset as per your post in another thread - hit power button to put to standby, unplug power cord, then push front button and plug power cord and kept button pushed until light beside usb port started flashing.
Yes - if playing, the album artwork is missing from the Now Playing screen.
I tried the following:

  1. I copied one of the rips from the internal drive to the downloads folder on my NAS,
  2. I copied an old rip done using DbPoweramp from a backup to the Downloads folder of the internal drive and also to the NAS. A copy of this file is already on the NAS and on the App the cover is displayed.
    All the copies showed up on the App but without the cover art.

In the downloads folder the artwork is traditionally supposed to be called folder.jpg but presumably Naim know what they are doing. The only other thing about added artwork is that it mustn’t be too large. 1000x1000 is ok. If you look at the artwork in the coverfront.png and userartwork.jpg in one of the rips that doesn’t show artwork, are the files about the same size?

The old rip I copied from my backup has the artwork as folder.jpg. An exact copy of that file is already on my NAS and the artwork is shown. But the copy I did today doesn’t show the artwork.
The size of userartwork.jpg is usually smaller that the coverfront.png - e.g. 129KB vs 1MB. Since coverfront.png is made by the Core itself, then the size should be correct.
As I said, this just suddenly happened a few days ago. Up to that point, rips had artwork shown and if not, I was able to add it using the Edit Metadata function.

Ok. One more question. I’m assuming that your internal drive isn’t nearly full (as that can cause unpredictable errors to occur)?

But otherwise I’m out of ideas for the moment. Perhaps some other Core users could say whether they have this issue…

You could email Naim Support again and refer them to this thread, which will show them all the things you have tried…



The Samsung drive is 2TB and only installed new just a month ago.

Sure, but one guy I remember filled his 4TB drive to 90 something per cent overnight by importing music from his music share and it didn’t go well!

Very sure there is lots of space left in the drive. I only have 10 Cds ripped to the drive plus only one Cd in the downloads folder.

Any other Core users out there seeing this issue? It would be very interesting and helpful if there are?

I’m assuming this didn’t start after you did a Naim app update, or an IOS update?



The problem started three days ago.
There was an IOS update to 14.5.1
Can’t remember when that was done but pretty sure it was before this problem happened. I think I did the IOS update a couple of days before this problem started. I think I ripped a couple of CDs after the update without issue. But this problem may be related to the recent IOS update.
But I also have Google phone in the house and the cover art also does not show on the Android App.

1 Like

Power the network components down and restart the router, then bring it all back up again. This did the trick when all my artwork started disappearing.