Supernait 3 problem

Evening all,

Have gone to use the SN3 tonight and have been greeted by a strange zip in the left speaker and another in the right channel. The zip was tame and then faded to silence.

No music is coming out of the SN3 either channel, in any input, with any devices, neither through headphones or speakers.

Have checked other components.

Any thoughts what has happened? Seems like something has failed.


What do you mean by zip and tame? Did this happen when you switched it on? Is the logo still lit up? Has the fuse blown?

Adam, are you able to elaborate more here? Have you powered down? Then tried again? Is it working ok? Or not working at all now?

If the latter, have you checked the fuse? It’s by the iec inlet…

Hi everyone.

Thanks for the notes.

Yes I have powered down. No change.
The unit lights are on. I hear the normal static hiss from the tweeter but when playing sound into the SN3 it is not playing them. Either on headphones or speakers.

I haven’t checked the fuse but as the system is on and powered I am guessing it’s not a fuse problem.

Just no sound.

The zip was like a strange audible whine. About 2 seconds long and then stopped. Like piiiiiiing and then off.

Logo on. Lights on. Volume control working. Electro interference is hitting the speaker when you couple the RCAs in and out.

Just no sound.

There is no silly misses here. I’ve gone over everything. It just seems to have died.

Power down and then remove the link plug at the back and then refit it. Then try again.

1 Like

If you are getting hiss from the speakers, a noise when you connect something and all the lights are on and the remote working, it sounds as if it’s the source that might be the issue. Your profile mentions a Hugo as source - are you sure it’s working and outputting a line level signal?

I will try Richard’s suggestion.

FYI HH I have tested using my phone direct to the Nait with single mini jack 3.5 to 2xRCA as well. No sound. Definitely some sort of amp issue.

Trying the power down and link removal now.


No luck removing the link plug and restarting.

I think it’s a call to Naim tomorrow.


Thanks guys,

Have you played around with Mute when it happened? My SN3 lost one channel when I muted it. Stuck relay. Never succeeded getting it unmuted and had to be repaired at naim HQ.

Hi Slamdam, tried mute naturally. No effect.

I can’t get my head round it. Something inside is simply not processing the sound.


Ditto,mute,stuck relay,naim repair.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.