SuperUniti flac files wont play

All .flac files on USB portable HD that have previously played are now saying " unsupported format" the .mp3 files still play fine… Help is it something i’ve done unknowingly

Are the mp3 files on the same USB drive? If not, I wonder if there’s a problem with the drive. Perhaps you can try the same FLAC files on a different drive to confirm?

Yes same hard drive…mp3 folder full of bands and their albums… And flac folder full bands and their albums… Was working last time used it (has been couple months,mainly been playing vinyl)

They should still work. Have you tried a power off restart of your SuperUniti?

Yes, switched off unplugged, left for few minutes, restart… still same… the . flac filesplaying on laptop in media player legacy and groove music from this USB external HD

Have you tried copying known good versions onto a different USB stick to see if they will work? That might rule out the possibility of a corrupted drive.

Just done that, onto 64gb stick copied from laptop 2 albums Pearl Jam - Vitology and Porcupine Tree - Closure/Continuation, same issue Unsupported Format.

Also .wav files play as do .mp3

Also transferred to Phone as music app plays .flac and work fine.

Was thinking setting on SuperUniti i have messed with but seems not… maybe need do factory reset… please no

It sounds like you have done all the obvious things.

Are you able to stream the Flac files to your SU from your PC to see how it handles it?

It may well be worth a call to Naim on Monday.

I doubt it’s worth calling Naim on Monday as there hasn’t been any change to the firmware of the SuperUniti for a year or more.

Resetting to factory options is worth a try as it’s free and you have the answer 5 minutes later. But it’s hard to know what could be wrong.

UPDATE… left resetting to factory settings intending to do today as other events took over last night (fireworks​:boom:) anyway before attempting reset connected HD today and initialising took awhile then showed “error” unplugged tried again it initialised fine and both flac folder and mp3 folder music playing… Due tp this Fickleness have decided my superuniti must been one female ones they manufacture on friday just before hometime :thinking:

Thankyou each of you that took time to chip in…

Sounds like your USB HD might be intermittently faulty to me. So I suggest copy the files to another one asap.

Can’t be HD… 1 it finds all the flac/mp3 folder/files 2 it also (see post above) finds all flac/mp3 on a 64gb USB stick… Most likely issue with superuniti when initialising drive and/or stick not enabling .flac

Did you actually try the factory reset?