Synology Nas now you see me now you don't with NDX2

I have a Synology DS920 NAS with native music server and plex server installed. I have ripped my CD collection to it since a good chunk of my collection can’t be found on streaming apps. Problem is that the NDX2 sometimes sees the NAS and sometimes it doesn’t. This is not a minute to minute variation but more like day to day. On the naim app “servers” would not show the nas for a whole day or so and the next day the server would be present and working wonderfully for a few days.

Restarts don’t necessarily solve the problem. Everything is connected via ethernet cable. I have linksys mesh wifi 2 or 3 with three nodes. The NAS is connected to the main node (the one that is connected to the ISP’s modem) while the NDX2 is connected to a secondary node.

All thoughts welcome

Must be a real frustration for you. Can’t think of anything obvious, but a couple of thoughts.

  1. Have set your MESH to assign a fixed IP address to both NAS/NDX2 devices? Shouldn’t be required, but may help.
  2. Do you have the latest MESH firmware installed, and/or did the problem occur when you updated the firmware before.
  3. Can I suggest you copy your entire music library to USB drive, and shove in the back of the NDX2, then you always have a copy of your music to hand. This may reduce your frustration. (I just use a USB drive, as I love simplicity, and it always works)

Hi @flame_rose

When discovering & using the UPnP server the NDX2 is not part of the equation. Primarily:

1 - the Naim app uses ssdp (port 1900) to discover upnp devices on the network and then shows the servers.
2 - the server of choice is then browsed and this is done exclusively between server and app.
3 - when something is played, the app populates the playqueue, with all the track url’s from the server + metadata and the ndx2 plays them.

In your case it sounds like is failing at stage 1. The ndx2 only gets involved at stage 3.

Most likely cause is the wifi router is not bridging upnp discovery messages (udp port 1900) to/from wifi <->wired interfaces.

Have a look through the routers setting and see if there are any setting on wired and wireless traffic bridging, udp traffic throttling or similar. Also, if you have a PC that is wireless connected then see if it can discover the server in the ‘network’ view of windows (as a upnp server, not as a network share).

Also as a final one, check the os version running on the phone/tablet. If iOS upgrade to 15.2 as some recent iOS versions have been quite buggy on quirky security issues and traffic filtering.

Best wishes

Steve Harris
Software Director
Naim Audio Ltd.

1 Like

I am not really up to speed on linksys stuff, but be jesus its expensive for what it is. Years ago I had some of there stuff and it was not a good time, but I digress.

What is the ISP supplied router and is it doing the routing, is the mesh system simply the APs?

Sometimes, but not often, my ndx2 does not show my nas drive via the app. A restart of the app usually sorts it out. My ndx2 and nas are wired via switches to my router. Obviously my naim app is connected via WiFi.

Have you set your NAS to go into sleep mode when not in use?
I originally did on my Synology and it always took a while for me ND5XS2 to detect it.
I altered the settings on the NAS to be always awake.
Never had a problem since. I use Asset however, not sure if that makes a difference.
Apologies if I have missed the ball on this one.

Waking Synology from hibernation takes about 30 seconds, the app shows a spinning wheel during this time.

It is worth checking what the discovery time on the Synology is set to, (SSDP advertisement time)
It can be found on this page.

Reducing the interval may help.

And is a frequent source of problem by itself if done by users who aren’t networking experts. It is barely ever necessary and most people are much better off with automatic configuration by DHCP.

1 Like

I have found it useful, but of course I am one person, with only my own experience, so happy to bow down to your experience. Certainly take your point that it can be confusing to people without networking knowledge. Everything should work out the box without needing the knowledge, but unfortunately thats no always the case.

Of course in certain classes of problems it can be useful when done correctly.

However, people set fixed IP addresses without fully realizing the significance, then don’t do it right or forget that they did it. It tends to complicate things.

DHCP is only a problem when misconfigured itself, typically by having more than one device acting as a DHCP server and handing out IP addresses. The better solution in this case is to fix this.

(By the way, DHCP and fixed IPs are not mutually exclusive. Decent routers let you set a fixed address for a device that nevertheless is assigned by DHCP. It’s typically a simple checkbox in the router configuration page of the device.

And by the way as well, decent routers will assign a DNS name to the IP, based on the unit’s name in the Naim app. I’m always surprised that people are using bare IPs so much)

I should have been more specific in my answer by saying “assign a fixed IP address in the DHCP config section of the MESH” (not on the device), as in this case I believe the OP has everything connected to the MESH, which is a good idea. Problems arise when you connect one device to the MESH, and the other to the router as certain network traffic will not get broadcasted across both networks (something I fell foul of even though I know a bit about networks).

I see the OP hasn’t responded yet since their initial question, so perhaps we have all confused the hell out of them - sorry of thats the case

1 Like

Thanks to everybody for the very informative replies. Will do the trouble shooting once the NAS dissapears as it is currently visible and accessible from the NDX2.

Just to avoid any confusion, everything is hardwired with cat6 cables including the NDX2. The iphone with the app obviously isn’t

I had a similar problem with server input. Solved by upgrading ios 14.8 to 15.2 on iphone. I did not want to do this upgrade but tried and it worked in my case. I have backuped up iphone so i can return to previous version anytime…

If everything else is hard wired, to by pass wifi, an iOS tablet can be hardwired. Use appropriate internet adapter, either usb-c or lightning to rj45 and then add a patch cable to router, I use a generic one. (If ordering from one of the usual sources, be sure to choose correct configuration.) The are one or two on the forum who connect this way; works seamlessly. Info from apple suggests iPhone can do the same. To use the adapter, connect direct or through a switch, go to settings, switch off wifi and the next item in the left hand column, will appear as “Ethernet” assuming you have achieved a connection. Good to go. If any problem isn’t present with control point hardwired, trouble shooting will be simpler.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.