Synology update 7.0 broke my music store!

I still rip cd’s from the Unitiserve. But listen to them on the Uniticore. After updating the DSM to 7.0
I lost the connection Unitiserve to the NAS(DS418PLAY). Every time I make a new music store I get “cannot authenticate share”. The Uniticore/Naim app is showing the shared folder music. That is great news. But failed on promoting Unitiserve’s Music Store. I did these changes trying to fix it.

Deleted and made a new share empty folder

SMB1 thru 3 enabled

Local Master Browser enabled

restarted everything many times over.

Full week trying to pick up all the pieces on this. Thanks for reading, regards Rick

You need @Mike-B for this one, he’s the DSM guru here. Hopefully he’ll pick this up.

Hi @analog414 , you have enabled SMB1 on the Synology but I think you also need to enable NTLMv1 authentication for the UnitiServe. Look in Advanced Settings > Others for the “Enable NTLMv1 Authentication” option as described here:

I think this problem is specifically covered in the Asset forum

I am sorry for not mentioning that I did enable NTLMv1.

@analog414 Rats, I thought that would fix it. I had a similar problem accessing an SMB share from a device that only supports SMB1 and enabling NTLMv1 fixed it in that case.

@Mike-B I don’t think this is an Asset permissions issue – as I understand it I think Rick is having problems accessing a music store from his UnitiServe, so this is an authentication/permissions/SMB issue between the UnitiServe and DSM7.

Any UnitiServe users out there using DSM7 that might be able to help?

Rick, it might be worth contacting Naim support for assistance with this.

Many thanks Adrian_P for your reply. I tried Asset and that failed as well.

I believe you are correct. The Uniticore is showing all files from the NAS so it must be a “write” issue

OK, it needs a US/Core expert, I much prefer the simplicity of a PC with a one of the better UPnP server software packages.

This topic is now resolve thanks to Naim support that had such an easy answer! I had minimum SMB1 set and maximum set to SMB3.

Minimum SMB1 & Maximum SMB1 IS THE CORRECT SETTING! For the Uniticore on this problem. Thank you Naim Audio!

Regards Rick

Case closed

2 Likes

I think you mean for Unitiserve? UnitiCore is fine with SMB3.

Correct! :slight_smile:

1 Like

I tried minimum SMB1 maximum SMB2 and that worked. Maximum SMB3 does not work.

Unitiserve only works with SMB1.

As no-one uses anything but SMB3 these days and SMB1/2 are equally deprecated, if you set the Synology to minimum SMB1 maximum SMB2, it will go for SMB1. But if you set it to minimum SMB1 maximum SMB3, it will default to its preferred setting of SMB3.

Good answer David. This is why I had such trouble. Default to SMB3… I was wondering why this did not work! Thanks for your memorable reply! Rick

1 Like