System Automation (sorry - again)

This used to work on my system, and for some reason it doesn’t now. Cant think of anything significant that has changed recently. Equally (since the problem became evident) I have shut everything down due to the recent thunder warnings and restarted but no change.

I can select inputs using the Naim app and I can play/stop tracks, and use the arrow keys to move forward and back on the track listing. However, I cannot control volume or the mute control.

I am using a NDS streamer (2015 model) into a NAC 282 preamplifier (2014 model), with the 3.5mm cable connected at both ends (I’ve tried 2, both have good connections when tested). On the NDS Sys Automation menu I have Pre-amp enabled, and the audio stream connection for the streamer specifies CD (which is the input my streamer uses on the 282). I can’t find anything else in the NDS manual I need to set. In the Naim App (ver. 5.13.1) on my iPhone XR I have “enabled” CD input, Aux 1 and Aux 2 - I have been through the rest of the menu and cant find any other setting that relates to System Automation.

My only thoughts are that this may (not 100% certain of this) have happened since I updated the app on the iPhone. I haven’t updated the firmware on my NDS (still at 4.4.00) as I don’t really want to do this

  • has anyone come across a mismatch between this firmware and the latest app version?

Secondly - when I check the app on the iPhone initially I see all three inputs I have specified on the front screen (along with Tidal, UPnP etc) and also all three enabled in the Input Setting menu. However, after a few moments the input that the NDS is connected to seems to drop out - I can’t see it on the front screen any more, and it doesn’t show as “enabled” any more in the Input settings menu. I’ve tried connecting the NDS to all three of those inputs (changing the audio stream setting each time) and the same thing happens - it is always the input the NDS is connected to that drops out.

Does anyone know how to overcome this? Or is this a normal thing?

Many thinks for any help.

Have you tried stopping and restarting the Naim app? By that I mean swipe up from the bottom to the middle to get the app changer screen then swipe the Naim app upwards, swipe up from the bottom to get back to the home screen and then reselect the Naim app?

One time, unbelievably, the RC lead I was using between my NDX and NAC broke - failed continuity test.

Cost me a dollar to fix.


Thanks - afraid I have tried that, I tend to clear all the apps from the iPhone quite often to refresh things.
Plus I have checked the cable(s) and the continuity seems fine.

Hi johns,

If your preamp has never been back to Naim, it may require a hardware update to facilitate reliable system automation operation.


Not sure if I have a useful explanation for this, out of curiosity, does the NDS remote control the 282 volume?
You might try resetting system automation (Settings > Factory Settings > Reset sys. Automation > Yes) and setting it up again from scratch.

I’d forgotten about the point that @NeilS makes. If you don’t know the history of your 282 you can ring Naim technical support with the serial number and they will be able to tell you whether it’s ever been modified.



Thanks, I hadn’t done this - but having tried it (no success I’m afraid) I did find out that I cannot “enable” the preamp input that the NDS is connected to using the NDS remote - it doesn’t matter which input I use (in my case CD, both Aux inputs tried) whichever one is connected will not enable, the ones that do not have a din connected will “enable”.

Neil - does that confirm your view that the problem is with the preamp and it needs to go back to Naim? If so, do you mean I need a service (5 years old?) or is it just a tweak?

Also - I’ve seen another thread where the problem was that the RC5 input socket had been wired out of phase - is that what you have in mind?

Thanks for the help all.

PS - yes, the NDS remote does control volume on the 282.

Hi johns,

I haven’t experienced the input enabling issue you mention.

The 282 shouldn’t require servicing yet, so it probably just needs the mod.

I think that the out of phase socket will prevent the system automation from working at all.

Edit: If you give the factory a call with the serial no, we should be able to give you a good idea of whether it needs the mod.


Thanks Neil, I’ll do that on Monday.

Hello again,

I did a quick check on this today & the h/w mod was introduced in 2012, so your 2014 unit will have this implemented already.
Having not seen the issue you are experiencing, I can only suggest updating your NDS to 4.7.0 to see if it resolves it. You can always go back to 4.4.0 if you wish.


Thanks for checking that out Neil - good news and bad news in a way. Having to send the preamp back would have been awkward (long way from my dealer but I live 10 miles from the factory!) but I am a mac user so Ill need to get hold of a windows laptop and the proper usb to mini usb lead I guess.

Thanks for your help though - I’ll update on whether the update to 4.7.0 works in due course.

I’ve done every NDX update using Macs. A bit tricky, but works fine after installing the USB driver.


I didn’t realise you could do that…but I need the laptop to get close to the NDS as well. It seems easier to connect the usb to a laptop close to the NDS rather than move the NDS (plus 555PS) to my Mac.

As a matter of interest, I have a good wifi signal near the hifi - so the NDS is hard wired and the laptop would be on wifi - presumably that will be OK to do the update?

Yes wifi to the laptop is fine.

I’ve done several updates over WiFi in the past with no problem. There will be a slightly higher chance of dropouts causing problems, but that never happened to me.
The alternative is to but a long Ethernet cable just for that purpose, and run it temporarily, as they are extremely cheap.

Yes — any computer USB-wired directly to the NDx should be fine. The update is downloaded to the computer first; so a live Internet connection, WiFi or not, while installing the upgrade is not required.


I’ve installed new firmware many times. I’ve always run it fully wired with ethernet on my own NDX because it says so in the instructions & because for me it’s so easy with component locations & I have the wire ready to use.
I’ve also done it for others, NDS & SU, both have Mac laptops & no ethernet ports, so after first being sure it was OK (‘cause the instructions at the time don’t say it is) I used wireless

A USB to Ethernet adapter works fine for me with a MacBook.

1 Like

Sorry Nick but this is a bit misleading. Yes the update is downloaded to the PC or Mac first, but it is delivered to the streamer in parts, the first part over the USB connection and the last part over the ethernet (or WiFi) connection.

It’s true that the PC/Mac doesn’t need an internet connection during the update but it does need an IP address and it needs to be able to see the streamer over the ethernet/WiFi connection, so the streamer needs an IP address too. In practical terms the PC/Mac and the streamer need to be on the home network.