Taming metadata

I have ripped about 1500 cd’s to my Qnap 251+ But some have decided to go where they please rather than where they should. Try as I might, I cannot get them to behave so am looking to the collective for an answer.

I am using dbpoweramp and asset upnp to play through a Nova and a Muso Qb.

An example is Jethro Tull. It should go under J, but no matter what I do it goes under T. How do I get it to go under J? Grateful for help.


Try SongKong

I suspect its how its been named in the Album Artist tag.
I have Synology NAS but I do have Asset UPnP
My Jethro Tull(s) are all browsed & found under J, the Album Artist tag is ‘Jethro Tull’
You can check & rename each album with dBpoweramp.

If it is correctly named, it might be possible to change something in your config settings, although the only changeable line that I’ve found thats similar is ‘The’ Album & Artist Handling, but thats just the ‘The’ word AFAIC
This is my config if it helps

1 Like

Thank you @Mike-B, had a look through but so far nothing has got Jethro Tull to land in J. Also Third World lands in W, but Teenage Fanclub lands in T. Can’t figure it out. :woozy_face:

It goes where the metadata tells it to go. Just check the artist using dBPoweramp.

1 Like

Out of 1500+ cds, only a few artists have ended up in the wrong place. No rhyme or reason that I can see. HH, I agree, it goes where the metadata tells it too but I can’t figure out what is different to all the artists who went in the right place. I need to dig deeper, but this is not my area of expertise and factorial in my sticking with cds.

If you’re using dB Poweramp set the following:

Album Artist: Jethro Tull
Artist: Jethro Tull
Album Artist Sort: Jethro Tull
Artist Sort: Jethro Tull

It’s very likely that you have artist sort or album artist sort set to Tull, Jethro

If you’re using a different metadata editor the same applies - it’s most likely you have the sort items wrong.

If you haven’t changed Asset’s sort and display settings that should fix it.

I’ve got Asset set to “Smart” in the first box - Your setting shouldn’t change Jethro Tull though, just the Rolling Stones, etc

1 Like

Hi @TallGuy, I tried exactly that because it has worked so many times before for me. Not this time. I have deleted Jethro Tull from the nas drive and tried re-ripping them, and I think some metadata from the previous rips has got stuck in there somewhere and is re-writing itself every time I rip. Need to sort it out some time coz it’s driving me nuts. Thank you for the idea though, much appreciated.

Out of interest, can you browse to your library with Windows/MacOS/Linux . If so how is Tull listed ? Try by going through the file system and Then browsing through the “Asset” entry in explorer in Windows (sorry, don’t know about the other two)?

If the folder is Tull Jethro what happens if you rename it, then the metadata on the folder to match ?

I’ve exactly the same kit as you it seems and I remember seeing this before, but not how I fixed it. It didn’t involve re-ripping, I’ve never done that.

Graeme, what does the Album Artist tag actually read in your problem JT album?

Jethro Tull

It’s all 12 of my JT albums doing the same thing.

Are you looking at the actual metadata by right clicking on the files stored on your nas and choosing edit id tag, and not just altering the file names, which achieves nothing?

No, I’m altering tags in dbpoweramp, which normally works wonders for all sorts of problems but Jethro Tull is being stubborn.

How strange. Maybe strip the artist and album artist tags, save the changes and then retag. I’ve had a few weird albums and eventually have found a way though. The other option is just to live with it.

I can strongly recommend mp3tag for tagging. I have found artist inconsistencies are often down to the Album Artist tag being set inappropriately.

1 Like

Haha! Yes. I’ve done that for some time now and may well continue to do so. I was just checking over my database and nas drive with all this time on my hands and thought it was time to sort this out. But I’m only inclined to drive myself insane up to a point.

I’d be happy for you to mail me a few of the tracks and I’ll see what they do here and if I can fix them. Rest assured that as I cannot abide Jethro Tull I won’t keep them and infringe copyright. It’s my forum name at gmail dot com.

1 Like

Cheers HH. If I don’t get it sorted tomorrow I may well take you up on that kind offer.

I’ve tried to reverse engineer your problem, but am failing miserably.
All my JT Album Artist tags are written Jethro Tull & show in all the Asset browsing as Jethro Tull - i.e. under the alphabetical J’s.

I tend to use Mp3Tag for editing, but dBp does it as well & its been a while so I gave it a go & I took some screen shots of stuff while I was playing, if its any help, then help yerself