The Atom can’t connect via AirPlay

Hi Guys,
I have a problem with the connection between my Atom and my IPhone via Airplay
Already saw a similar discussion from 2020 but the topic is closed without a final solution…
Has anyone had a similar problem and found a solution…?
Thanks in advance!


What problems are you having? AirPlay works fine with Naim streamers for me.

After searching and finding the Atom…the IPhone shows message : Unable to connect… you can find some photos attached


Are those pics from the ‘Home’ app. I never use that and just select Airplay destination from control centre/now playing.

What control centre do you mean…this??

You don’t need to use the Home app, just open the AirPlay screen from within the app you want to play from and select the Atom from there.

What do you mean…Aiplay screen…? From what app?..Sorry if I get annoyed but I have so far used airplay only with Apple TV, which is a product of Apple and the connection is done by scanning the device … and codes that must be entered on both devices …when switch to airplay I only see my Apple TV as a device…

I have added my Star and MuSo in the Apple Home App without issue. This is needed so you can tell Siri to play music in a named room. Maybe you have a network issue? Try rebooting your router and Naim devices.

1 Like

He means that you can make the Airplay connection from within the Apple Music app if you are trying to play music from your iPhone to the Atom.

Ok, but as I mentioned above I don’t see the Atom…attached you can see

I thought that was the MyHome app - ChrisSU was referring to connecting via the Music App. It might help if you explain what you are trying to do with the phone - eg just play music?

As you can see from the photos above…I tried both ways…through Home and Music…nothing!

Just reboot the router and the Atom…still nothing….

I’ve just tried this. I don’t have Apple Music but I do have Qobuz. If I touch the Airplay button a screen pops up that lets me choose where to send the music. I just select sitting room, which is my NDX2, which works like the Atom. I then close that screen, choose the music in the Qobuz app, press play and it plays through the NDX2. You even get the cover art. There is no need for codes or any setting up, it just works.

One thing I also checked: the Airplay input needs to be enabled under input settings on the Naim app. Hopefully this is your issue.

Sorry, I didn’t recognise the Music app. Have you tried establishing a connection via the Naim app to see if you can find the Atom via that route? If not then I guess there is some wifi issue. I had a problem with my Musio QB using an Apple Express extender. It seemed that if the Muso connected to the Express and my MacBook, or phone or iPad was on the Apple Extreme wifi, the Muso behaved as if it was on a different wifi network and didn’t connect.

Hi @desned

This seems to be fairly common, especially with even slightly complicated wifi setups (extenders, repeaters, access points, etc.) but is not very reproducible, nor do people with ostensibly identical setups see the same results. It can be frustrating for someone to say “it works for me” when it doesn’t work for you!

The broadcast beacon for “I’m available as an AirPlay (or Tidal Connect, or whatever) end point” happens at boot-up (or if you make any network facing changes, such as re-naming your device). It’s supposed to be preserved in a services list, but sometimes seems to get lost crossing switches or access points or whatever.

You could try going to the AirPlay selection screen in whichever app you like - Music or Tidal both work fine here - and then power-cycle your device. As it boots up, and broadcasts its availability as an AirPlay endpoint, it should show up in the list. If it does, try it and confirm it’s working. Sometimes, due to network topology and the available services list not getting preserved across hops, it will disappear after a while… so you don’t see it at all when you go looking later on. Solving this is more complicated but definitely related to your wired / wifi infrastructure and not really anything to do with the Naim device or app.

Starting your diagnostics with this test might point you in a useful direction. Good luck!!

One thing to check is that you did enable airplay input in the Atoms inputs menu on the Naim app?

I already check that …was enabled…

Thank you guys to all of you for the involvement and for trying to help me!

Today I took the device to our apartment in the city center, where the internet is better … because we generally live in a house near the city …:wink:
I turned on the device and everything started perfectly … @CliveB and @alan33 are right, the problem is with the Wi-Fi network in our house, I’ve already talked to our Internet provider and tomorrow they will send a technician …

Thanks one more time, you are great guys!

Glad to hear you have narrowed down the problem and your Atom is working properly - good luck with getting the wifi sorted out.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.