The End of DSLR's

I’ve been a Ricoh GR user over many years and still take my GRii (I didn’t bother with the ‘new’ one) with me on hols etc.

Fully controllable, dials and switches, easy menu system, same sensor as in Nikon ASPC dslr’s, 28mm equiv. lens and it fits in your pocket. Unless your pockets are in your favourite skinny jeans.

Everyone should have one!

Ah , I extracted the memory card - all the trial photos are showing in slide show on the camera.

So I doubt it’s card.

After the first batch failed I tried a second batch , some as raw and some raw and Jpeg - and I have pictures !!! The pictures are Jpeg

The picture shows 5.2 MB whereas all the blank squares show 26 MB , so I am thinking it’s the camera , and not the card or computer

As the R10 is relatively new I suspect most software drivers are only now just being updated to cope with it’s raw files, that’s
the penalty of being an early adopter🙂

Anyhoo, try updating your software if not already…


So… the problem is (just) the RAW image files…? You can pay me later… :laughing:

The problem is that the devices you have tried, cannot ‘read’ the R10’s RAW files. Agreed…?

@Jamiewednesday has beaten me to it. The R10 is very new - so software updates are likely needed…!!! (I did mention this before, though…)

We had a similar problem with the Canon R6. Seems the built-in card reader of the iMac is unable to read SD cards above a certain size. A USB SD card reader plugged into the Mac solved the problem.


Sure it’s not software not recognising the latest Canon R raw format, as I found? That seems more likely to me, unless you know the software does recognise the latest format?

1 Like


1 Like

No. Software. Of the reading device(s).

The Canon R10 is a very new model, so… likely not being recognised.

(As has been suggested already - multiple times…)

1 Like

Camera only released this week

1 Like

:astonished: :open_mouth: :roll_eyes:

You know… you don’t get this problem with older cameras… :laughing:


Well here are my Canon 4000 D and the R10 side by side

One was the smallest lightest camera in the old range (a frustrating camera, in that I want to like it , and it produces good photos -but the software is a little weird ) the R10 aimed at enthusiasts , but at the same size and weight of the previous entry level

Once I get the hang of the R10 it seems like it will be a cracking little camera .

IMO, the problems found (reading the Canon R10’s RAW files) should have been easily & quickly resolved, by the retailers - or Canon’s - support. Its pretty shameful, if this was not the case.

@Ian2001 - What did the retailer - and/or Canon - say…? You did contact them…?

Yes, by email yesterday.

Much happier now that the problem is firmly identifiable .

I should have learned about being a first retail user after my experiences with Mini ( both BMW and I came to the same conclusion, that the car was subject to demonic possession)

but it’s all written down and I’ve had a note acknowledging it

I am reasonably relaxed

best wishes


1 Like

Hang on… Only 1 hour ago, you posted saying you still had problems…?

Yet just now you say you had been told by your retailer and/or Canon (which was it…?) what the problem was, yesterday…?

IMO, you could have been clearer… :thinking:

it was the comments on this forum (especially yours) that helped me identify the issue , I was very unclear up until about an hour ago. Been busy with card readers etc this morning

Yesterday I had a camera that would not take any photos, now it will take certain types - and I wrote to the retailer this morning with a much clearer picture of the problem -thanks in part to your comments

best wishes and many thanks



Pleased you have found a way forward - without sending your R10 back (hopefully). Glad to helped, if only in a small way. The retailer could have done better - IMO.

PS. I have never owned a ‘current’ DSLR (all of mine have been well past their Sell By dates) - or any Canon camera… :astonished: And I only shoot jpgs… :roll_eyes:

1 Like

The retailer should be telling you to download and run Canon’s latest DPP software.
Did you tell us which software you are trying to use to interpret the R10 RAW files?

1 Like

As others have mentioned it is likely that the codecs for the raw files are not available yet. A way around this is to use the canon software that came with the camera to convert RAW files to another format. Adobe are pretty quick at releasing updates for newly released camera RAW files and the Adobe RAW to DNG converter might have R10 codec already and your current software is highly likely to be able to read DNG files.

Microsoft can take months to update the codec and I expect Apple can be just as slow sometimes, which means until they do, you won’t be able to see the RAW files in your file viewer etc.


Went on Canon , to get latest software , they didn’t recognise the serial number…

1 Like

Th camera is so new Canon didn’t recognise the serial number

Anyway I shot in Jpeg and here is a result