The odd little idiosyncracies of my Naim Uniti Core

Does anyone else have these problems?

Album art disappears on my app display. I’m a real obsessive sort about my metadata. Everything has the proper cover art. But today about 1/4 of the Artist display lacks cover art. I get the little anonymous outline instead. Opening the album sometimes causes cover art to reappear, but not every time. This happens fairly often. Once all album art disappeared for several days only to reappear as mysteriously as it disappeared.

And then there’s this little mystery: When I add a new album and it turns out I have to supply cover art, I will locate a copy of the CD on the ‘net and “save” the cover art in the iPad’s photo library. But when I follow the procedure to “use cover art” (“edit metadata”, “change cover art”, “photo library”) about half the time I won’t find the image I’ve put in my photo library. Sometimes I have to keep trying repeatedly, as long as 5-10 minutes or more, before the image will show up in the app metadata editor.

Does this happen to anyone else?

Not personally came across this…did have a new cd that ripped up to the point of storing but failed to show, but then did rip and store after 3 days. Always worth a power down from the mains and then plug in again. If its still a problem try rescanning the database which depending on your number of cd,s could take a few hours.
Perhaps @davidhendon has some better ideas, he usually does.

I rather think Gazza’s faith in me is a bit misplaced! I don’t use Artist view although I do recall that if you have more than one recording by an artist you get an outline whereas if there is only one recording by that artist on the Core you get that cover art.

The problem of not being able to successfully edit album art is something I have seen a couple of times, but not recently. As I recall I found it best to come right out of metadata editing, select a different album then go back to the one I wanted to edit and try again. Mostly that worked. I do remember some discussion in the beta group st the time but it was in the old forum and so I can’t go back and check.

And overall I agree with Gazza’s advice of doing a full power off restart of the Core if it ever misbehaves.



Are your files in WAV or FLAC format?

If the latter, use an MP3 editor (eg, MP3tag) to ensure the image is embedded in the music files themselves. Then delete any image files in the folder where the music files are stored to avoid conflicts with the embedded images.

Personally I prefer keeping my music files in FLAC because of the greater flexibility in creating and maintaining metadata. There are other advantages to FLAC as well (portability, forward compatibility).

You mustn’t do this to any files that have been ripped by the Core or another Naim server because it will break the indexing, which would be a major hassle potentially. It shouldn’t be necessary anyway.

Also with the Core you can’t transcode to WAV on playback so storing in FLAC is likely to have a SQ impact.



Oops, I’d missed this being a Core discussion when I made my post above, deleted.

1 Like

Oops, I mistyped. It’s Album view, not Artist view.

OK! This isn’t a problem that I have ever seen myself so I don’t have much to add from last time we discussed it. I think restarting the Core is always a good thing to do and clearing the image cache in the app is another one, but otherwise it strikes me this is some sort of network peculiarity. Assuming you tried restarting the router and WiFi access point(s) too, then J wonder whether it might be worth trying another WiFi access point/router. I forget the details of your network but your phone/tablet shouldn’t have any problem seeing the artwork images stored in the Core…


I do try doing something else, anything to let time go by, as time seems to eventually take care of this problem. But I do find it quite annoying, I have sometimes tried to see how many times I have to repeat the steps to get album art and once it took me 20 repetitions before the elusive photo showed up and I could select it.

As to the other problem, I was planning to do a core reset if the problem persisted today, and i see it has.

I would try a restart first. You really shouldn’t ever need to do a factory reset.

I left the cord unplugged for a minute or so without correcting the problem.

Resetting the app changed nothing either.

Like I said, the mysterious idiosyncracies of the Naim Uniti Core.

Ok I would try restarting your router and restarting the Core again. No need to leave the power off for mire than say 30 secs.



I wish I could report that worked…
I guess I’ll just have to wait until it decides to correct itself.

I wonder if Naim reads our forums and notices things like this that could perhaps be put on the bug list to be fixed.

Naim sometimes does read them, but the official advice is not to assume that and report the problem using the function to do that via the app.

This is not a commonly reported problem, at least not in the forum, and even if Naim try to deal with it, they have to be able to duplicate the issue first. So it’s worth reporting it as well as waiting for your Core to fix itself.

The other things you could try would be to factory reset your Core or rebuilding the index on your Core. Note that the latter takes quite a while so is something to do just before you go off to bed, not first thing the next day!


somethings the cover art takes a little time to get into the photo library. I have found that it is always there but never takes more that closing the app and retrying.

I have this problem with the editor frequently. I’ve tried various things to reduce the time I have to wait for album art to be “seen” by the editor.

First, it’s important to understand that the copy of the album art photo appears in the photo library as soon as it is copied. It’s just that for some mysterious reason, the app editor can’t “see” it.

I’ve tried both closing the app and not closing the app and repeating the editing, but it’s unpredictable how many repetitions are necessary. I’ve sometimes had to repeat this 5 and 6 or more times before the editor can “see” the desired album art to use. And sometimes I’ve had to give up and just wait.

I’ve tried putting several copies of the album art in the photo library. This actually seems to help, meaning I more often find the album art on the first try. But, frustratingly, not always.

Waiting always works eventually. But I haven’t found out how to predict wait time.

My record for artwork appearing in the app from my Unitiserve is 3 months! I suspect it’s fussy over network setup, as it now appears quite quickly.
One thing that does cause a short delay is storing in FLAC, as the Unitiserve first saves the rip in WAV, then converts it, and artwork doesn’t show until the conversion is complete. Perhaps the Core handles this faster, as I believe it has a more powerful processor?

Are we talking about the same things?

I don’t see any lag time at all in a photo appearing in my photo library. I find the correct album photo, usually by searching Amazon, do a “save image” command on my iPad, and then I can poke a finger on the icon for the Photo Library on my iPad and i will always see the album cover I just saved there. Never any lag time.

The lag time for me occurs in the editing process. The steps in my iOS Uniti Core app are: “edit metadata”, “change cover”, “photo library”, “use”. Use brings up the Photo Library and if I’m lucky, the album art will be there and I can select it. If not, then it’s time for a few words of frustration. FWIW, my files are WAV, but I can’t see how that would matter at this point.

No you and Chris are talking about different waits. I am familiar with his wait which I also met with my Unitiserve. But I haven’t seen your wait for a photo to show up in the Naim metadata editor, although it’s true that I rarely use that as I can almost always find what I want online.


No! I meant when you rip a CD. Once they have first appeared, for me they always stay there.