TIDAL and iRadio does not work in NDX

Good afternoon,
I have an NDX network player and for a few weeks TIDAL and the radio stations have stopped working, however the playback of all my discs on NAS works correctly.

Radio: When selecting the radio entry, the cursor appears circling and does not get to see anything, neither genres of stations, nor countries, etc …

TIDAL: I log in, then the menus to select artists, album, etc … appear, it lets me search for the music I want to play but when I select it it does nothing, it indicates that it adds the tracks to play them but does nothing.

I have updated to version 4.8 and have also tried 4.7 but I still have the problem.

Can you help me?.
Thank you.

Try:

Unplugging the NDX for a while to force it to factory reset

Change your Tidal password (again it might force something)

Do you the latest App?

  • TIDAL login authorisation update. NB: Also requires Naim App 5.22 or 2.22 or later

This was included in software update 4.8 which came out in September 2021.

Hope this helps.

Hi,

This is most likely a bad dns or default gateway setting in the network config.

Go to:
Setting->factory settings->system status

Report back what the setting are for ip, netmask, gateway and dns1&2.

Best regards

Steve Harris
Software Director
Naim Audio Ltd.

That’s not how you factory reset an NDX!

Sloppy wording by me. I mean forcing it to properly restart after the update.

Thanks for your help.

I think I know where the problem is.
the gateway that appears on the NDX is 0.0.0.0, I don’t know why it is.
I have checked it through the IP of the NDX (192.168.1.4) on the screen of the NDX I can’t because the display no longer looks good, I have to replace it.
If that is the problem, I cannot solve it until I change the display and can enter the menu to configure it correctly.

This is the configuration that appears:

DHCP State: off
IP address: 192.168.1.4
Net mask: 255.255.255.0
DNS1: 80.58.61.250
DNS2: 80.58.61.254
Gateway: 0.0.0.0

Greetings.

Hi Stevesky,
Can the NDX be configured from a PC or does it always have to be from the NDX menu?
Is it possible to do a factory reset from the NDX keyboard without having to enter the menu?

Thanks

Hi,

The problem looks like the device has been configured as a static IP device (so user enters the network details manually) and the gateway has not been entered.

To factory reset it (and hence get it back to DHCP mode), turn the device off using rear switch. Press and hold the front panel “Stop” key. Turn it on while still pressing the stop key. Wait about 5 secs and release the stop key… on front display (if readable) it will say press “play” to confirm factory reset. Press the play and it will then factory reset and restart.

Hopefully it should then be on the network.

Best regards

Steve

1 Like

Hi Stevesky,
I have always used it with a fixed IP, I don’t know why the gateway IP has been deconfigured.
I have reset the factory with the instructions you have given me and it has worked well, with the automatic DHCP it has assigned the IP of the Gateway and the radio and Tidal are working correctly.

The only thing I have not achieved is that the volume control appears in the Naim app, I do not know how I can activate the automation system without using the menu.

Thank you very much for your help.

Hi @Cponce

This is a front panel feature only. You could try and do it blind by following the menus in the user manual.

Best

Steve

Hi Cponce,
As Steve said, with a dead NDX screen you could try and do it blind by following the menus in the user manual.

I have NDX with Supernait, (no CDP no DAC)
If it helps you, my system automation settings are …

NDX Display
In System Automation Screen
’ Pre-Amp > Enabled
’ Pre CD > No
’ FM Radio (Pre-Tuner) > Yes
’ Pre HDD > Disabled
’ Pre AV > Disabled
’ Pre Aux1 > Disabled
’ Pre Aux2 > Disabled
DAC > No
Streamer Audio > Pre CD
CD Player > No
Advanced Setting > No Entry

Hi Mike,
I also have the NDX only with Supernait.
I want to enable the same thing that you have, blindly it is complicated, I have tried several times but I have not succeeded.
Can you send me a picture of the menus? I can’t get it with the manual.

Thank you.

Hi Cponce, I’m not sure what you mean by pictures of the menu.
The only way I know to do this is starting from factory default, have someone map out the steps ….
down 5
right 2
down 1 as an example

I can do the mapping, but not today, or at least not until much later.

Press the spanner key

System automation is option 9 (8 clicks down)

Then you get this:

Each one of those is just an enable option

Thanks for your help.
Mike, when you can, I could really use the mapping.

Matthewjb, in the last step, in the Preamp, to activate it, press OK alone or another screen appears with the options Yes / No ?.

Just added another pic

Press OK. You then get through to a yes/no screen that is set to No. So select up and OK

Full disclosure. I’m just running through the menus. I don’t have automation set up myself as most of my gear is Olive

1 Like

If you manage to do it blindly, then you will be able to sort out the OP problem.

Its difficult to type with my eyes closed

I got it, I have activated the automation of the system.
Thanks Matthewjb, with your instructions and screenshots I have been able to activate it.
Thanks everyone for your help.

2 Likes