Tidal disappeared!

Tidal functionality appears to have disappeared from my ND555 and Muso 2 - i’ve just updated the ND to 3.7 btw. Updated my Muso QB to new firmware too and having signed in to Tidal all my playlists appear there but not on the other two players! Tidal app itself functions fine btw.

Any thoughts? I have tried the old switching on and off trick!

Also in case it’s linked my Core is recognised by the ND555 but the app doesn’t show any artists / albums etc.

Also is there any way of getting rid of Quboz as i no longer subscribe

Sorry for long list of questions!


You can disable the Qobuz input in the app Settings. While in there, check if the Tidal input is enabled and you are logged in; and try logging out and back in.

Hi Andy. Are you running the latest version of the Naim App? That’s essential for these updates. You need to be on at least version 5.22 of the App if you use an Apple iOS device, or 2.22 for Android. If you can, use the very latest versions of the App: 5.22.1 or 2.22.1

Thanks guys - have finally resolved the issues!

1 Like

Good to hear- what solved it?

Well i tried rebooting the ND, checked that the app was up to date but made no difference … could see all of my playlists but couldn’t play anything. In the end it was just a matter of logging out and back in to Tidal

Got the Core back by switching off at the mains then rebooting the router then switching the Core back on

So all simple stuff!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.