Tidal not working on superuniti

i am using the naim app to play tidal on my superuniti. recently, many tracks i showed “skipped track, cannot play”. can anyone help?

1 Like

You should check that you have the latest firmware version on your SuperUniti (which is 4.7). This included a fix for this Tidal problem.



Hi, I have the same problem on my NAC-N272. I had the problem before and after updating to V4.7
In a playlist with 11 tracks only 3 plays…

Have you tried signing out then signing back in again after the update?

i updated to version 4.7 and i could play all the tracks. yes i restarted the system after updating

Same here. The system is restarted several times, router aswell. The songs not playing is not to be found with Naim-app but works perfect i Tidal-app and on computer/web-browser.

If you’ve tried signing out of Tidal on your devices then signing back in again, and still no joy, then I would try contacting support.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.