Tidal on Uniti classic

Probably a stupid questions so apologies in advance.

Naimuniti (original model) received back from Naim today with latest firmware and hardware upgrade for tidal.

Sadly tidal dosn’t appear as an option in the much maligned Naim app nor on the front screen of the unit.

Does anyone have a clue how to get Tidal going?

Ps it’s up and running on a muso no probs using the same app.


Have you tried re loading the app ? or re booting the router

Welcome Bob. On the App try Settings, Input Settings and check Tidal is enabled.

1 Like

Hi and thanks for the reply.
Looked there but tidal isn’t even listed there to enable…

Try deleting the app and download it again.

When you say ‘hardware upgrade’ you are presumably talking about the 24/192 streaming board which is required for Tidal and some other functions, including Spotify, multiroom and BBC HLS support. Can you check that any of these other functions work?
The Tidal input should be enabled by default, and on opening it, you are normally prompted to log in. If none of this is working, I would get in tough with Naim and ask them to confirm exactly what they have done to your Uniti.

You could also check your firmware. It should be 4.7 which does include all the Tidal library. If Naim have left it at 4.6 and it got to 4.6 without going through 4.4 first, then Tidal and Spotify will be missing. This would be a schoolboy error by Naim though.

Thank you for all your input.

Turned out to be communication breakdown resulting in no 24/194 board being fitted. Now being done so all good.

Anyone know if this will support Airplay? Not that it would get a lot of use but would be good to know.

Good to hear that you’ve solved the mystery.
There is no AirPlay support, you would need to pick up an Airport Express and a Toslink cable for that (or maybe a Chromecast Audio) so there are cheap workarounds if you need them.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.