Tidal through Naim app issue again

As of last week can’t login to Tidal through the Naim app. Anyone else having this issue? Did the Tidal apk change again?

Welcome to the Forums!
No TIDAL issues that we know of. Obvious question, but have you (firstly) fully restarted the App? (A full phone/tablet power down/up recommended, not just closing the App.)

1 Like

It’s worth logging out of Tidal on the Naim App and the logging back in again.

1 Like

I had a ‘no connection’ message from Tidal this afternoon, solved by rebooting my Unitiserve.

I had logged out of app but hard restart of phone worked. Had something to do with the android update I think.

Thanks for the suggestions!

1 Like


The app, as well as the Tidal issue, was showing no results when I tried to play music from the US hard drive. Happens occasionally. A reboot cured that and fixed the Tidal issue as well.

Hi there,
I seem to be having this issue too. With a Uniti2 and SuperUniti2. I changed my Tidal password and since then I get the “cannot connect to Tidal server” message. Tidal is working fine with the new password on tablets and phones.
Have done a hard reset on phone and power down and restarted both Naims. Was going to update the Naim firmware.
Any ideas?

Any special characters in the password? I seem to recall this was an issue with Tidal passwords in the Naim app in the past (though may have been fixed in updates), although such passwords worked in the Tidal app

Hiya, thanks for the response and yes, it has a comma in it. Worth a try. Will report back!

Hi there, I am afraid that didn’t work. Still getting the ‘cannot reach Tidal server’.
Will try Main unit firmware update next…

It was worth a try :slight_smile:

Hi all,
I still can’t login to Tidal via Android Naim app on my Uniti2 and SuperUniti2. The trouble seemed to start when I changed my Tidal password.

I have reinstalled the Naim firmware version 4.7 and reinstalled the Naim app to no avail.

I get the “Could not reach Tidal.server”
Any suggestions anyone please?!


Have you used any non alpha characters e.g. &%# etc

Have you tried logging out of Tidal in the Naim app then logging back in again?

Hi there, in the Naim app I couldn’t log in at all. But re-installing the app and updating the firmware seems to have reset something on the account. It is WORKING now!
What a relief.
Thanks to all for the suggestions.

1 Like

Glad you got to sorted in the end. For future reference if you go to Settings > Input Settings > Tidal you’ll see the login and other stuff there.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.