Trying to automate NAC 282 from NDX... And failing

I am trying (unsuccessfully) to automate the operation of my NAC 282 from my NDX. I’ve emailed Naim support, but, while waiting for a reply, I figured I’d ask the community as I am sure that I must be missing something obvious…

I have connections as follows:

  1. NDX connects to AUX1 on the 282 over DIN.
  2. A 3.5mm jack in the NDX’s ‘remote out 1’ runs to the ‘RC5 in’ on the 282. This is a mono 3.5mm to RCA cable (I’ve tried with a stereo cable as well).
  3. Preamp automation is turned on through the NDX’s ‘System automation’ menu.

This all seems per the System Automation Configuration document (

The preamp source inputs appear in the Naim app as do the volume controls. The NDX responds when selecting these source inputs, but the 282 doesn’t; neither does the 282 respond when changing the volume through the Naim app.

I’m at a loss as to what’s wrong. I’ve reset settings on the NDX and even tried connecting the NDX to the 282’s CD input; no difference: the 282 stubbornly refuses to respond to remote commands from the Naim app. The rc5 codes [viewed in the NDX’s ‘Advanced setup’ menu] are all set to their default values.

Any advice you could give re. what I’m doing incorrectly would be really welcome. Thanks.

Did you enable “System Automation” in the Naim App?

That’s a common reason for it not to work.

Bart, reading the opening post, it appears so. Only time I’ve come across a similar situation, it was down to the lead - trying a different lead and all worked fine. No idea why…

Thanks both. I thought the cable when the stereo one I initially tried didn’t work (on either left or right channel). Unfortunately the mono one I subsequently bought doesn’t work either. Reassured that I’m not doing anything obviously stupid :grinning:.

Hi smennis,

Is your 282 a few years old?
There is a hardware mod required on earlier display PCBs to ensure reliable system automation operation.
I cannot recall exactly when it was implemented, but I can check for you?


Hi Neil,

I suspect you’ve hit the nail on the head - my 282 is vintage 2004. Does that sound pre-mod?

Thanks for you help!


Assuming the 282 is the same as my Supernait. The following is the NDX display menu I use. It might be worth checking your settings against it
I have the NDX connected to the Supernait’s CD input, also included is a NAT05 FM tuner

NDX Display - System Automation
Pre-Amp > Enabled
Pre CD > No
FM Radio (Pre-Tuner) > Yes
Pre HDD > Disabled
Pre AV > Disabled
Pre Aux1 > Disabled
Pre Aux2 > Disabled
DAC > No
Streamer Audio > Pre CD
CD Player > No
Advanced Setting > No Entry

It absolutely does sound pre-mod!
The mod consists of a resistor value change (surface mount) & a resistor added to the RC5 opto-isolator IC on the display PCB.
I suspect the Class A in Sheffield or similar competent dealer could do it, or of course back to base.


1 Like

Mike-B : Thanks for taking the time to reply - appreciate it. That matches one of the settings combinations I tried with no joy. Good to know I wasn’t been dumb.

Neil : Thanks again. That’s definitely going to be the problem. Frustratingly, I only had the 282 serviced back at base mid-Jan. Would have been nice to take control from the app, but I can live with using the remote or hand cranking the volume control (first world problem :grinning:).

Edit: Sorry - meant to reply directly!

Oh! That’s odd - the mod should be done as standard on all returned units.
Did you receive any paperwork with the returned repair?


I was expecting some paperwork listing what had been done, but there wasn’t any in the nice new box that I did get. If it accompanied the shipping docs then the dealer took those.

Regards, Mark

Do you have an RMA number for the repair?

I can look into this to see if the mod was specifically noted against the job.


No RMA on the dealer invoice, but I recall seeing such on a sticker on the box. I’ll take a look tomorrow (it’s in the attic) and let you know.

Thanks again.


If you are willing to post the serial number of the unit, I can also use that ?


No problem, I’m a bit obsessive about keeping notes & I’m on the beta test team & you need those setting each time I run a factory reset. So 1 minute to copy/paste & you have it.
Hope you get it sorted.

Got the RMA: 53162. Should be NAC 282 service on that (53162/1) plus a NAP 250 DR upgrade and service (53162/2).

Thanks, Mark

Smashing - leave it with me, I’ll check it out & get back to you as soon as I can (probably tomorrow evening).


Mark - while you are waiting for Neil to check out the service details, have you tried ‘remote out 2’ on the NDX just to rule out any issues with ‘remote out 1’. Worth checking if you haven’t done so already.

1 Like

Hi James - Definitely worth checking, but, alas, no joy.

Oh well - worth a try anyway. Hope you get it sorted ok