U-Serve - wobbly power button


I have a wobbly power button on the back of the U-Serve. I had noticed it before when I last turned it on as the green logo flickered as I touched the button.

This morning, I powered down the U-Serve to do some cleaning and now it will not power up and I think it’s to do with a bad connection on the power button.

Is it a good idea to open it up to take a look inside for starters, or should I send it to my dealer straight off?

I wanted to upload a quick video showing the Wobblies, but I am not sure how to do this.

The video format from the iPad is not supported, any ideas.

Post it onto YouTube then paste the share url as you would a url to an image.

When you say”wobbly” do you mean it moves around slightly within the chassis cutout?

That’s right Richard. I know there should be some movement, but I think mine has more movement than it first had.

Il try to get this little video demonstration up.

Did this work?

What’s the verdict from the floor?

I don’t think the fact the switch moves around like that is a problem per se, but if moving it causes the logo to flicker then that is a different matter and it means that either the switch is faulty or there is a bad connection to the switch, which seems unlikely as it will be soldered.

If you are the sort of person who is comfortable about going inside a computer then you could have a look inside the US. I would certainly do that if it were mine. But unplug it from the supply and the ethernet first and be careful not to touch anything without ESD precautions.



Thanks David,

I just returned from an afternoon walk. I will make a visual inspection to check the contacts and I will report back tomorrow.

A brief update.

So I tried to power up again, I pressed the switch down and up about 5-6 times, nothing happened until I wobbled and pressed the whole switch in a little, or finger pressure pushing on the switch as it was on, this worked and the U-Serve powered up.

So that suggests to me a ‘contact’ issue somewhere as it just did not power up for the first 5 attempts rocking the switch.

I will open it up tomorrow anyway as I am intrigued to see what the problem could be.

Ok. I am a little unsure about how to open the U-Serve.

There is one large bolt on the bottom, which I presume holds the chassis and cover together. I have taken that out.

Then there are a number of smaller bolts on the back, which may or may not be related to taking the cover off.

Any guides on this?

You have removed the main bolt and earthing washer. Now remove the hex bolts holding the feet. Then, very carefully slide out the chassis from the cover. Make sure you are taking full ESD precautions otherwise you’ll end up zapping the chips inside (but you’ll only know this later on).

Thanks Richard.

Here is a shot of the inside by the power button and a short video. As you can see it’s completely sealed but moves as a whole, so there is no way of determining if there is anything wrong within. The cables are obviously looking fine and dandy to the point where it enters the plastic/rubber housing.

Anyway, it looks inconclusive at this point.

Well I was just about to make another frilling video to show how it does not power up when I turn the rocker switch to on and I was demonstrating what to do to my wife so I could video the green logo, and it powered up on the second attempt.

I think I will just live with it for now, hopefully it will not fail completely, although this is a real possibility if it’s a problem now.

The mystery of the U-Serve wobbly rocker switch continues. And I have learnt how to post MP4’s.

It still boils down to what I posted before. The wobble doesn’t matter at all. But if the logo flickers then either the switch itself or the wiring to it is faulty and it needs fixing now before it does any real damage. My suspicion is a faulty switch, but nothing to do with the wobble.



Yes, I agree, it’s not the wobbles.

Then to fix it would require a trip back to Salisbury as I doubt my dealer would touch it. Il give him a call.

You could suggest to your dealer that temporarily he (the forum rules prevent me suggesting that you could do this yourself) could re-solder the switch connections to be always on, because you can control the power at the mains plug. That would also allow you to confirm that the issue is with the switch itself.

A return of a US to Salisbury is very expensive, to be avoided if at all possible, because Naim will only do a full service and charges accordingly.



Thanks David, I may consider that option.

If it’s the switch then i would imagine any competent pc/electronics engineer could fix it.