Unable to cast Qobuz on Uniti Nova

My iPad does not connect to my Nova. I cannot see the Chromecast icon in the Qobuz App. My Nova does not appear in the list of available device in the Qobuz App. With Spotify it does not work as well.

My Nova is connected to my router by wire. I can select internet radio stations and other sources from within the Naim app. I can adjust the volume from the app. Everything else works.

I found a similar problem in the forum, it was said that it could be a router firewall problem, I checked the firewall is OFF. Also I deleted and reinstalled the Qobuz App and the Naim App, with no result.

I have asked the Qobuz to help me, but I have very little support.

Does any have any ideas?

Regards, Jérôme

1 Like

Are the Qobuz and Spotify inputs enabled in the Naim input settings menu?

Spotify is in the settings menu.
And as you probably know, Qobuz is not integrated in the Naim Uniti Nova. So I use Chromecast to cast Qobuz. When i select Chromecast in the Naim menu, it gives a list of available compatible apps, one of them is Qobuz. I select Qobuz, then Qobuz opens, but at this time Qobuz cannot detect my Naim, and even more there is no Chromecast icon !

Jerome did this ever work for you? What I mean is are we trying to solve a new problem that suddenly happened one day or have you never been able to get this to work?
Best

David

I had similar problems, over a year ago, where Chromecast devices did not show up in some apps. Sometimes they would show up as AirPlay but not CCA. More recently I have found that these devices, including 2 Naim streamers, are always available. Is the software up to date on all your devices, including the OS on your controller? Is that iOS or Android?

Jerome, chromcast is a crap. If you want Qobuz, install Mconnect app on your iPad and select Nova then Qobuz. The sound is much better.
Bonne écoute!

David
yes it worked perfectly well. This is a new problem. I think (but i am not 100% sure) that it appeared after I changed my modem router.

Hi Chris
I am on iOS.
I have deleted then reinstalled Qobuz from the Appstore, so it is the very last version.
Regarding iOS on my iPad, version is 10.3.3 and is up to date according to what Apple says in the settings.
Good to know that this is a new problem, meaning that it used to work well… I have recently changed my modem, is it to consider?

I’m wondering if your iPad is the problem? iOS10 is relatively old compared to the current iOS13.3 (or iPadOS) so perhaps Chromecast does not work so well on older Apple devices.
Perhaps you can try it with a newer device to see if that works? Also, does it work with AirPlay?

It could very easily be the router/modem, but I’m not sure what the problem is exactly. Maybe Chris has more insight than me (as I don’t have a Nova).

Best

David

I was wondering about the router, but as the firewall is disabled, I’m not sure what else might be affecting this.

No it does not work with Airplay…
I tried using my iPhone X, same symptom…

Following Frenchroosfer suggestion, I have downloaded Mconnect lite (free) on my iPad, for a trial. Well, perhaps I am stupid, but the result is not fantastic… I click on “play to” then I cannot see the Nova in the UPnP devices, I just see the iPad, and also the TV decoder, “my own flow” and “Google cast” which is not active…

@anon64018693 tried recently with his nd555 and was very pleased. Perhaps he could say you what’s wrong.

You should see normally the Nova. I didn’t do it since some months because my WiFi is not stable and the app crashes. But it worked on my nds and recently on @anon64018693 nd555. He will very probably answer you.

So neither AirPlay nor Chromecast are working at all? Do they work with any other apps or is the problem only with Qobuz?

@Jerome have you tried restarting your router? Sometimes a router works fine for some protocols but not so well for Naim because of poor implementation of standard protocols in the router.
If you are restarting the router then I would turn off the Nova and restart that after the router has settled.
Best

David

DO you have Google Home installed - I can’t remember if you need that for Chromecast support generally.

Not tried it for ages but under ‘Play To’ on iPhone I see:

‘iPhone/Airplay’

UPnP Devices:

Nova

GoogleCast:

Nova

1 Like

Chromecast support is also licensed, I seem to recall some time ago Naim had to update the licence info with Google for a few users after some updates or reversions.

If you don’t resolve it after network router/device restarts (and potentially resetting the Nova to factory settings) I’d contact Naim support.