Unable to change ID tags - help please

Anyone had this problem or can help out.

Just set up a new computer with Windows 11 and usual method when downloading music is to create a folder on my desktop and download music to this folder then tidy up the files etc by right clicking on the track scrolling down the menu to “Edit ID-Tag” before transferring to my NAS.

But I get

If I press retry it does work eventually and changes the correction I have made but the process just to do this for one track is quite long.

If I Google the issue get this

But when I try to change the tick box from read-only it keeps changing back to this screen - all users have full rights.

Have you tried a shorter file path?

1 Like

It’s a long time since I’ve touched windows, but I think that Read Only icon suggest there are various permissions set under that folder for different users.

I’d go to the “Tidy Music” folder, go to properties like you did for Desktop, but this time try clicking on Advanced, and there may be an option there to set User permissions recursively.

Or as HH suggests, try a different folder rather than Desktop

Looks like a File Permissions problem, to me…

With @GadgetMan on this… :expressionless:

Thanks everyone. I have looked at the permissions and changed the owner of the folder to ‘Everyone’ who has been given:-

But the box with the minus sign on blue won’t stay unchecked it stays checked or blue with a minus as below

OK getting somewhere if I go to the ‘details’ tab rather than Edit ID tag option, I can change the information I.e. Album Name etc

So it is the Edit ID tag that is the problem that doesn’t work - why is this linked to dbpoweramps?

Problem solved - updated to a more recent version of dbpoweramps.


Good to hear it’s solved and now you can listen to the rather wonderful Be Bop Deluxe :sunglasses:

1 Like

I can highly recommend the free Mp3tag for editing tags

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.