Unable to play some recorded music

Don’t know if anyone has any ideas, but I have copied all my CD’s to a hard drive to play using my Uniti Atom
I have 1200 recorded and all works well apart from a couple which the Atom does not acknowledge or appear to recognise their presence.
They appear in the NAIM app and play on all other equipment.
I’ve tried various formats from mp3 through to FLAC and still no joy.
Is there a missing identifier? Anyone else had the problem or have any ideas/solutions?

Thanks in anticipation of someone having the knowledge.

Just to clarify, you can see them and select them to play in the Naim app but nothing happens? Can you give an example CD?
Is this hard drive just plugged into the Atom and you browse it, or do you use a UPNP server like Asset?

Do the titles have any strange characters in, such as # ?

Just plugged straight in via USB.

One of the albums is Bookends by Simon & Garfunkel.

I can see it in the app but when you click on a track to play it just doesn’t recognise It and contest to either play what is already playing. Even if nothing playing it still doesn’t register.

All other CD’s play, and just tried in my car and it plays OK.


Not any visible characters that are showing on the file data.


Sorry instead of “contest” it should be “continues”.
Damn predictive text!

And any particular file format difference? Just trying to rule out anything obvious!

I haven’t compared with other recorded files in the same format but have tried copying in various formats and none work.

What was the original format of these files? Anything different to the other files that play properly?

Simple m4a (Apple Lossless). Recorded directly from CD and no other source.
Tried on FLAC and mp3 with no difference.
Thinking there must be some missing “flag” on the CD???

I’m guessing that you’ve tried deleting and re-ripping it.

Yes, tried that with no success.
I’m going to compare file names with working copies to see if there are any differences (odd characters or something missing). Not sure what I’ll see but it’s worth a go.

When you say ‘recorded’ do you mean ripped from a CD? Presumably on a Mac using iTunes/Apple Music? If so can you rip the CD again and save it in a different format, maybe try WAV.
Also are these standard Red Book CDs with no DRM?

Big thanks to all responders for their time and comments.
Re-visited post from Claire and realised the artist has an & in their name (initially looked for odd characters in the track title).
Changed the “&” to “and” and it works.
Minor fix but it frustrated me all day yesterday!!

A big thank you to all.


I happened to me once. I opened a topic on that, like you here. Some asked me to share the file here. Then @Suedkiez explained to me that something like the metadata was too long. It was a Meshell Ndegecello file. Do you remember Suedkiez?

Glad to help!

I remember FR! The filename for each track was huge!

1 Like

Glad it’s working now, but I’m surprised the ampersand caused the problem. I can play a WAV ripped Bookends with Artist Simon & Garfunkel on my Nova with no issue, I’d have expected the Atom to be the same. Obviously the important thing is that you’ve got it working.

Yes, it’s an odd one as it’s only a problem with the file name. The individual tracks play and show on screen with the “&”.
It just doesn’t seen to pick up if the file name has the “&”.
Confused me anyway.

I tried to find it and failed, but your post jogged my memory. Indeed the file names were huge and this didn’t matter as long as it was zipped, but after unzipping the path + file name became too long for Windows to handle. @frenchrooster @kevincfulham, It was here:

1 Like