Unable to play some recorded music

Not any visible characters that are showing on the file data.


Sorry instead of “contest” it should be “continues”.
Damn predictive text!

And any particular file format difference? Just trying to rule out anything obvious!

I haven’t compared with other recorded files in the same format but have tried copying in various formats and none work.

What was the original format of these files? Anything different to the other files that play properly?

Simple m4a (Apple Lossless). Recorded directly from CD and no other source.
Tried on FLAC and mp3 with no difference.
Thinking there must be some missing “flag” on the CD???

I’m guessing that you’ve tried deleting and re-ripping it.

Yes, tried that with no success.
I’m going to compare file names with working copies to see if there are any differences (odd characters or something missing). Not sure what I’ll see but it’s worth a go.

When you say ‘recorded’ do you mean ripped from a CD? Presumably on a Mac using iTunes/Apple Music? If so can you rip the CD again and save it in a different format, maybe try WAV.
Also are these standard Red Book CDs with no DRM?

Big thanks to all responders for their time and comments.
Re-visited post from Claire and realised the artist has an & in their name (initially looked for odd characters in the track title).
Changed the “&” to “and” and it works.
Minor fix but it frustrated me all day yesterday!!

A big thank you to all.


I happened to me once. I opened a topic on that, like you here. Some asked me to share the file here. Then @Suedkiez explained to me that something like the metadata was too long. It was a Meshell Ndegecello file. Do you remember Suedkiez?

Glad to help!

I remember FR! The filename for each track was huge!

1 Like

Glad it’s working now, but I’m surprised the ampersand caused the problem. I can play a WAV ripped Bookends with Artist Simon & Garfunkel on my Nova with no issue, I’d have expected the Atom to be the same. Obviously the important thing is that you’ve got it working.

Yes, it’s an odd one as it’s only a problem with the file name. The individual tracks play and show on screen with the “&”.
It just doesn’t seen to pick up if the file name has the “&”.
Confused me anyway.

I tried to find it and failed, but your post jogged my memory. Indeed the file names were huge and this didn’t matter as long as it was zipped, but after unzipping the path + file name became too long for Windows to handle. @frenchrooster @kevincfulham, It was here:

1 Like

Ah the ampersand. It’s not a problem in file names on Windows and Mac, and usually not in Linux (which the streamers are using). In Linux, however, it has a special meaning and some tools occasionally have a problem dealing with it correctly if it’s part of a file name. It can be dealt with, so my guess would be that the firmware should be able to and it’s some kind of bug that it didn’t

Thanks my friend :+1:
I don’t know if it will help the OP, but maybe.

1 Like

For ages I was puzzled by my QNAP NAS renaming a few files with weird names until I discovered that the original names had characters forbidden by the OS used by the QNAP. The relevant tracks played fine, it was only when I looked at the contents of the NAS with Mac Finder that I came across the strange names. All corrected now.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.