Unit Nova not showing in app

Dear all,

Since I could not find a thread addressing this, I’ve opened a new one.

My one-month old Uniti Nova is hooked up by ethernet cable to our wifi system in a small (80m2) apartment where wifi connection is never an issue.

The Naim app is installed on my iPhone 11, which is also connected to the WiFi network. All equipment is running the latest software.

Until a few days ago the Nova would appear immediately in the App - since a few days it does not work at all, despite restarts and resets of both iPhone and Nova.

Could someone who has had similar issues please tell me how they solved this, if at all?

For such an expensive piece of kit I’m honestly disappointed with the performance of the software and am considering returning it to the vendor.

Many thanks in advance for your tips!

Kind regards,

Paul

Welcome to the forum Paul. Naims software has a problem or two, one of which is discovery of devices. Mine is simply slow where it used to be instant. Have you tried dragging the screen down to force a search for devices. Works every time with my Nova. I know it’s annoying and shouldn’t happen, but I’m hoping for a fix in the next firmware update. Persevere, it’s worth it.

Thank you Graeme, much appreciated. Glad to hear you found a work-around with your Nova!

The unit is now connected - I connected the Nova to the WiFi network, then plugged the ethernet cable in again. I don’t know whether the Nova is now connected through WiFi or ethernet, but at least it turns up on the app again.

What’s less satisfying is that playing albums from Tidal is a real hit-and-miss. I’ll often select an album, press play, and see either nothing happen, or witness the album art appear on the Nova screen but no music coming out.

Have you had similar experiences?

Kind regards,

Paul

Worth checking to make sure your Nova has latest version of firmware. What you are describing used to happen regularly before latest version. Otherwise sounds like you need to talk to your dealer

Not had that experience Paul. I would be inclined to talk to your dealer and see if he can help. As @crispyduck says, is your firmware up to date?

Might be worth powering down and rebooting everything inc router.

1 Like

Paul,
I had the same discovery issues, although it’s easy to blame Naim (and I’m sure something could be done software/firmware wise), I assigned my Atom a static IP address in my router settings. It’s been rock solid for a year in terms of device discovery since I made the change.

Dave

Dear all,

Many thanks for the replies - really much appreciated! The Nova seems to be working now - once it starts playing up again, I will try the power cable and static IP suggestions.

Kind regards,

Paul

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.