Uniti atom doesn’t remember its WiFi

I have recently moved house and setup my uniti (attaching to the same network as it always did). The problem I’m having is that every time I go to use it, the uniti has lost all memory of the Wi-Fi router it was previously connected to. I touch the power button and I get a “play queue” logo, and it won’t stream anything until I go into network settings and re-input the very long router password. I’m on the latest firmware. Any ideas, anyone? Thanks in advance.

I suspect you need to put your Atom back on factory settings and set it up again from scratch with your new WiFi/router.



Sorry, should have said. I have already tried that, but will give it another go.

Is it exactly the same setup?
I.e. in settings (SSID, WiFi WPAx mode, access key/password for the network)?
Is it the same HW/router? (Maybe some change with regard to 2.4 GHz / 5 GHz, …?)
Does it still know which WiFi to connect to (and just cannot connect) or is it totally unaware which network to use?

But then again, factory reset hasn’t helped, and if it works every time you enter the password until you switch it off, and then it does not work any more… most ideas I have about problems (including the router kicking out/blocking devices to any kind of security setup) don’t match this description… :thinking:
… any chance to get an Ethernet cable connected?

Have you tried entering your IP address to connect that way?

The OP said he was having wifi authentication issues… putting in a manual IP address will therefore be irrelevant… as that means nothing unless you have authenticated your wifi.
It does sound like an issue unfortunately with the Atom and it’s non volatile memory.

That may be the case. I did experience a very similar issue to the OP where the wifi would just be forgotten and then not found. Entering the IP address solved my issue.

Ok - well if that is a repeatable case - did you report to Naim as a bug - because that very much would be and points to some internal instability or possible corruption that is occurring in the device, because IP address and wifi authentication are completely unrelated, or unfortunately it could point to a possible fault or unreliability with your device

For home networks most should really be using DHCP to assign IPv4 addresses (ipv6 is typically easier and different) and not manually configuring IP parameters.

Sorry to hear you’re having issues. I’d suggest emailing or calling Naim support - please reference this Forum thread.

The team has some great network diagnostic tools i’m sure it could use to help you here.

T: +44 (0) 1722 443405

Thanks for everyone’s help. Must confess that the Atom seems to have fixed itself all on its own. I reinput the Wi-Fi password one more time, and so far (a couple of days) it has been working normally. Thanks again.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.