Uniti Atom doesn’t see albums downloaded to SSD

Hi I’m using dbPoweramp to rip my CD collection as FLAC files onto an SSD to use with my Uniti Atom HE. What is happening is that the Atom will see the first set of files I download but any subsequent files I add aren’t recognised.
At first I thought it was a formatting problem as when I re-formatted the SSD and copied back the files. I could see all the new ones I had added on the Atom. But then I added some more and these don’t show up on the Atom.
I’m ripping from a MacBook straight into a folder on the SSD which is formatted as FAT32. The files it shows play fine it’s just any new ones added don’t show up.
Any help would be greatly appreciated.

Hi!

I’m inferring that it’s an external usb ssd and it’s plugged into the Mac when ripping… but then what do you do? Or am I missing something?

I assume you are plugging the SSD into a USB port on the Atom HE? If you add files to the SSD then the Atom has to reindex it. I think if you restart the Atom (put it into deep sleep, then wake it again) it should reindex automatically. But I’m not certain about that.

You could force it to do it by going to Other Settings in the app and then go down to Rebuild Music Database. But this isn’t by any means an instant process, depending on how many albums you have.

Maybe an actual Atom user could clarify what they do about this.

Hi Andy
Yes it’s a Samsung T7 external drive plugged straight into the Mac. I set up a folder on the drive to copy to and then directed the path from to dbPoweramp directly to the folder.
I then plug the drive into the USB on the Atom
It will see the files originally loaded but then doesn’t update any new ones I add later.
I am slowly going through my CD collection maybe adding 5-10 albums every session and was thinking it wouldn’t cause any issues doing it in small chunks but this doesn’t seem to be the case.

Hi David thanks for the advice, will give your suggestions a try and let you know how it goes. If correct it looks like it might be easier to wait until I have completed ripping the entire collection before I connect to the Atom.

Strange. If you look in the USB unput you should see the files straight away as it uses a simple folder view.
If you look in the Server input the files are scanned as you get a tag view which can take a bit of time, depending on the aize of the library, but they should all appear eventually.

I can’t see any obvious reason it shouldn’t work either, although suggestions above to prompt a rescan make sense.

Only other thought (not being a Mac user, and this probably doesn’t explain why a newly-formatted file system works) - do you need to dismount the ssd from the Mac so it actually writes the files? Have you confirmed the ‘new’ files are actually written?

If you have a windows pc - can you see ‘new’ files on that?

Granty,
I think the cause for your problem is the formatting of your drive to FAT32. If you are using a SSD you should be EXFAT or NTFS I believe. I would also suggest you make the drive specific for your music centre and re-format it from the Uniti (you will lose what you have on there doing this remember). Hope this helps.

I think if you re-format the drive using the Naim unit it gives you the option of NTFS (Windows compatible) or HFS+ (Apple Mac Compatible) with files stored as WAV or FLAC.

Thanks for your advice, the SSD was originally formatted as EX- FAT as purchased but it didn’t show my files right from the start so I changed the formatting to FAT, this worked for the original files but then the next ones I added didn’t show. I then re-formatted as FAT32 which added the later files and I thought the issue was fixed but then I added some more and again they didn’t show.
I haven’t tried formatting from the amp though so will try this.
On someone else’s advice I did clear the memory using the advanced settings and this allowed the new files to be show, so maybe the amp makes an image of the drive first time of use and then runs with that until it is reset?!

Hi David

I got it to rebuild the database and this fixed the issue, I guess this might have to be the way to get it to update going forward.
Thanks for your advice.

2 Likes