Uniti Atom loses wifi and resets while using Tidal

I just received my new Uniti Atom yesterday. And my unit keeps resetting while skipping through songs via the Naim app and via the Tidal app. My unit is updated to the newest firmware.

Am I missing something? If someone could help, I’d really appreciate the support. Thank you!

Is this wired or wireless? Does it do it on both?

Do you have local music files to try with those? You could try with a USB stick and playing them in the Naim app both through the server input (which should exercise the network) and through the USB input (which does not). This may help to narrow it down

It is set up as wireless. Router is about 5 feet away and is running at Download/202.65 mbs and upload/228.42 mbs. I’d assume that would be sufficient?

I don’t have a usb stick, but I can stream via airplay with no interruptions. It appears that the disconnect is only happening via Tidal.

I don’t have an ethernet cable right now. I can get one if that might solve the problem. But I’d think that wireless would be fine for music streaming.

*edit via both the Naim app with Tidal and exclusively through the Tidal.

Since the update did you do a full power down reset?

Sure it should, but a temporary cable would help narrowing down. By the way, what exactly happens when it “keeps resetting”?

I disconnected all power for an hour. Reinstalled the Naim app and the Tidal app. And then plugged everything back in. Firmware is 3.8.0 (5355).

Tried music via Tidal through Naim App, a song (or two) plays, and then the app says connection is lost, while the Uniti Atom then resets itself.

What is this reset, does it reset to factory defaults?

I think he means restarts…

Most likely :+1:

I did reset it to factory defaults, and then went through the new setup process again.

I’m not sure what is going on, but the “handshake” between the Uniti Atom and Tidal just doesn’t work for more than one song (including via Ethernet cable). Seeing that every other “handshake” works (Apple, Qobuz, Analog, HDMI, etc.), I’m assuming this is more an incompatibility issue between Tidal/Naim.

As such, it is disappointing, but I’m hoping that there will be a future Firmware update that will address this issue.

Because, other than the Tidal/Naim issue, I’m really enjoying this piece of kit.

It’s just that for everyone else the Naim/Tidal combo works, so something is off

My Atom has no problem with Tidal. Something is not right.

And… problem solved. User error on my part. I had to switch a setting on my router that allowed for 5ghz rather than the previously set 2.4… and voila! The Uniti Atom works perfectly with everything! Now, I’m going to go hide from you all in my embarrassment! But, thank you for all of your help!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.