Uniti Atom not seeing UPnP Server

I have been happily running my Atom on my home network for a couple of years and usually access music files via the Naim app/Servers - and then either the QNAP generic UPnP server, or something such as Asset.
This morning, as an experiment, I installed BubbleUPnP onto the QNAP, tried to hook it up to everything, failed, uninstalled it.
Ever since, the Naim has lost contact with the QNAP and it can see no UPnP applications at all.
I have restarted/reset the Naim, cleared the image cache on the app, rebuild the music database, restarted and updated the QNAP, restarted the router and restarted my phone. Firmware on the Atom is up to date.
Everything else is working. I can play out of Audirvana as I always can, so it is seeing the QNAP. I have checked other devices on the network and they are also seeing the UPnP servers however, for the life of me, I cannot get the Naim to see them. Its always been pretty bullet proof so this has confounded me!
Any thoughts greatly appreciated.

So, unplugged the atom for 30 mins, everything is back. :woozy_face:🤦🏼

1 Like

Gone again. I’ve reset back to factory settings today. Unplugged, reset the network, checked the NAS. I can see no reason why the Naim should keep dropping it’s link to the NAS. If anyone has any ideas I’d appreciate them. This thing is close to becoming an expensive doorstop!

Have you tried the good old rebooting of everything?
Turn off the Atom, shut down the QNAP, turn off your access points / modem /router etc.
Turn on the router/modem and wait for it to FULLY turn on. Then turn on any wifi access points etc. that you might have.
Let them all FULLY restart.
Finally, turn on the Atom and let it fully restart.
You might find that the full reboot returns normal function.

Thanks Blythe. I’ve systematically restarted everything however, I’ve not taken the whole system down and then restarted. However, I think I’m onto something. Last week I installed an additional router into my network. It’s been working fine but I think the issues have only started since that. I disconnected the router last night and this morning Asset is still showing on the Naim app which implies some stability. I’ll monitor through the day and will try your suggestion if problems arise again… thanks for your input though👍🏻

1 Like

2 routers without setting them up correctly equals network conflicts, they’ll both be trying to assign ip addresses via dhcp. If you do want a 2nd router, perhaps as an extra WiFi access point, then it needs to be in bridge mode and dhcp switched off.


Yes, you’re spot on. I turned off the 2nd router and all was well. Reproduced the error by turning it back on, however what was throwing me was it was intermittent. Anyway. Set it up as a Mesh now, working perfectly. An example of a bit of knowledge being a dangerous thing! :frowning:

BY adding a second router, I take it you are trying to get wifi in a dead zone in your house(?) if so, turn off DHCP in the new router. That should cure both problems.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.