Uniti Core displaying skeletons instead of album art

I’m reopening this topic with a more descriptive subject heading.

It’s now five days into my Naim Uniti Core displaying about 40% skeletons instead of album art on my Album display.

Album display looks like this:

I’ve tried resetting my app, resetting the Core, resetting the modem, all to no avail. I wrote Naim Support three days ago and so far have had no response.

Any ideas on how to fix this?

Is the artwork a true JPG and is it called FOLDER?

Essentially ech album you downlod should have a file inside, called: folder.jpg

Do you have a switch between Core and Router? I do, and even with this set up, i sometimes have to power down Core and Switch…then all is fine. No idea why?

So far I’m not using the Downloads folder(s). Everything on the Album display comes from ripping with the Uniti Core and editing with the Naim app.

If an album cover is created automatically at time of ripping, it’s whatever was chosen by the software.

If an album cover is not automatically provided by the ripping metadata, I harvest a picture off the Internet, usually Amazon. I “save” it to my iPad and invoke the Edit Metadata command in the app and “choose” the saved image. All those files appear to be jpg.

I should add that most of the past year that I’ve owned the Uniti Core, there are no skeletons displayed. None. But this is the second episode in this same year I’ve owned the product where the skeletons have appeared. In the first instance, now many months in the past, all album art disappeared. I had only skeletons on the app display. As I recall it took several weeks before the problem corrected itself. This time i have about 40% skeletons. I feel much more impatient this time, perhaps because I now have 900 entries to search instead of the previous 350.

Yes, I do have a switch between my router and the Core. I have three Ethernet requirements at my stereo, so one Ethernet cable comes into the switch and three exit the switch.

How do you power down the switches? As far as I know mine is just passive.


I just unplug the switch from their power source, replug their-power source and once all the lights are set to go green i start adding ethernet cables. Turn the Core, Streamer back-on. No idea why it should work.

I’ve had this happen before. A complete power down and power up of everything - Core, router and all Apple Airport kit - and a reboot of the app, and eventually all was fine. Seemed to be a network issue of some sort.

I’ll give it a try, but it just seems to me that if it were a network problem, all album art would be missing not just some. I have about 40% skeletons,

I’m wondering about this “passive” switch. I suppose you could have a switch that’s powered over the ethernet cables but it isn’t the way most people go.

If you read the forum Janet you will see a lot of people like a Cisco switch which is supposed to give a sound quality improvement. You could play with that later but for something that is cheap and foolproof for switching ethernet, I highly recommend the Netgear GS105 which will cost you about $20 on eBay or wherever.

If your switch is indeed not powered then I suggest you try a GS105 instead and once everything is working again then you could think about whether you want to go any further and look for a pre-used Cisco managed switch.



I’ve must searched my Amazon archives for the switch I bought and it’s this;

Netgear 5 port Ethernet Unmanaged Switch (GS105NA)

I’m not sure what difference the NA suffix means, but it looks like I have something very similar. I see now I should have used the term unmanaged instead of passive.

I’ll look into the Cisco switch. I am always looking at improving sound.

Something interesting happened today when I opened my app to the Album view. I could see that more skeletons were being populated. I could watch it happening. The mystery was why some skeletons were skipped and not populated. So I am going to guess that the percentage of unpopulated skeletons is down to something like 20%. Isn’t this weird…

I should imagine NA means North America🤗

So that unit is indeed powered, and you restart it just by pulling the power lead plug out of the switch, wait a few seconds and plug it in again. The power lead is on the opposite face of the unit to the ethernet connections.



Pulled the power on the switch. No change.

Pulled all the power cords, one by one. Pulling the modem power resulted in ALL the albums becoming skeletons. But, interestingly, as I scrolled many repopulated. But oddly some are skipped.

This section was almost all unpopulated and one by one the skeletons filled out, but inexplicably, some did not.

Another irregularity has appeared. When I open the app, it can’t find my Uniti Core. At the bottom of the error message is an option to search again, which I do, and this time, it finds it. In the last 2-3 days, it always takes a second search to find it.


Hi Janet

Repopulating as you scroll is, I find, quite normal behaviour. But I always find that all of them repopulate quite quickly.

Regarding the app finding the Core, I have five rooms plus the Core. For several versions now the app is slower finding the Core than any of the other rooms. If I leave it, the app normally finds it on its own inside say 10 secs, but if I’m impatient then refreshing the room lookup by pulling down the screen and letting go, in the same way you refresh email in the iPhone email app, finds it immediately.

I’ve got no new insights into why your icons aren’t repopulating properly though.



No answer from Support in spite of two email inquiries. I finally stayed up late enough to call Support and they came up with a process that resolved my problem.

I had to pull the power cord and I had to hold down the power button and maintain that hold while reinserting the power cord and waiting more than 20 seconds for the unit to make a sound.

First attempt didn’t work.

Second attempt didn’t work.

Third attempt worked. The trick seemed to be to keep holding down the power button for some 10 seconds after the unit makes a sound, rather than releasing it soon after it makes a sound. Either than, or it simply needed three tries; who knows…

But I’m much happier now that my display has been fully restored!

1 Like

Hi Janet
The Core factory reset procedure isn’t quite as they told you.

Previously we have been told by Naim R&D that you pull the power cord, then holding in the on/standby button you reconnect the power cord, and keep holding in the button until the light by the front panel USB flashes, then you let go the button and let it finish starting as normal.

Anyway you obviously got it third time so I’m glad to know that it worked, because I was surprised that a factory reset hadn’t fixed it for you.



S[quote=“davidhendon, post:15, topic:2993”]
Previously we have been told by Naim R&D that you pull the power cord, then holding in the on/standby button you reconnect the power cord, and keep holding in the button until the light by the front panel USB flashes, then you let go the button and let it finish starting as normal.

That is just what I did, though my support instruction was to wait for a sound instead of a flashing light. Good thing, since I was behind the unit and couldn’t see a light flashing, so it made sense to listen for a sound instead.

The variable seemed to be continuing to hold the button well past the flashing light/sound.

1 Like

Do you have clear the cover image on the naim app or rebuild the database ?

I can discover no options for doing either.

Does your Uniti Core have those options?

You can find the “Clear image cache” and “Rebuild music database” in “Other settings” tab.

They are indeed there, as marcobb0312 says, but the once or twice I have come across this issue in the forum before, a factory reset of the Core was needed to fix it, like this time.