Uniti Core Firmware upgrade failure

I have a similar experience. I got notification about an upgrade through the App and went through the upgrade process. It showed the upgrade failed at the end and just left my device powered ON. After a few hours I still could not access/find my device. I tried rebooting power and still no good. I just turned ON my Uniti Core after having it powered OFF for around 4 weeks and still I could not find it. I followed the factory reset procedure on the Naim website and I could not see the NAIM logo lighting up at all. I have the standby button though ALWAYS with light ON all the time after plugging the power.

Is there any reset procedure for this?

Sadly, after almost 9 weeks the part still hasn’t arrived at the dealer. Very frustrating.

To complete the circle: The part for my Uniti Core finally arrived at the dealer early this week and I have just received an eMail letting me know that the Uniti Core is now working properly.

I can’t say I’m impressed with the time it has taken between diagnosing a power supply problem and getting the part. I do hope that Naim’s service for Australia, and the rest of the world where Naim products are sold, is improved. It should make us all wary of buying into a product where back up is so slow.

Thanks to all of you who provided useful advice.

2 Likes

I’m glad it’s sorted out anyway. Let’s hope that’s it now and it behaves perfectly. But if you run into any firmware/configuration issues, I (and no doubt others) will be happy to try to help.

1 Like