Uniti Core: Invisible Tracks

Perhaps someone knows what to do here … I copied my entire archive to my Uniti Core. For some old CD’s that were ripped with a NAD M50 I have the issue that the album is visible, the cover art is visible, but when I open the album inside the Naim app, there are no tracks. Yet the files are physically there, the metadata is correct and the file attributes are … Oddly enough when I connect to the same Uniti Core via UPNP, the album is visible, the tracks are and I can play the album just fine as if nothing is wrong …

Where did you copy them to in the UnitiCore? Also how did you copy them exactly?

I copied my entire folder structure into the download folder on the Uniti Core. It is setup in the same structure as identified by Naim, e.g. /artist name/album/files

I did meanwhile however discover the following… When I browse in Album mode, everything works fine. It’s in Artist mode that the issue occurs. Sometimes it takes an enormous amount of time, sometimes it simply won’t offer me the album selection list at all, preventing me from accessing the album I wish to play…

Maybe the data base has gone tits up, can you rebuild it somewhere in the interface, used to be able to old the older stuff.

There is an option to rebuild the database in the main settings menu in the app Home Screen for the Core.

1 Like

Done that a couple times already… :thinking:

Seems to be the exact same issue as Slow searching on Uniti Core query
Which was also never solved… Only in my case we are talking about 3tb / 50k tracks…

Additional info: This only seems to occur on Android devices (regardless of connection wi-fi or ethernet) … iOS devices do not seem to be impacted …

Hi yes my slow searching problem was never solved, despite rebuilding the database. I even went as far as putting a new hard drive in and re ripping my CDs! However I found that if I left my old Unitiserve on and searched via that the problem goes away! I would still love to solve the slow searching issue do I need to try to find a friend with an iphone?

Or an iPad… I have meanwhile determined that the issue can be reproduced with 100% certainty on every Android device I throw at it. My company iPhone and iPad however both work fine, regardless what way I browse through content via the Naim app.

(I would almost be tempted to buy the cheapest pre-owned iPad mini I can lay my hands on for the sake of operating the Naim devices)

PS I have meanwhile logged a support request with Naim on the issue.

Thanks let me know how you get on

Success! I bought a new Ipad 9th generation loaded the nam app and hey presto all searching functions work. I have been chasing server problems for god knows how long but clearly the is some kind of glitch in the Naim android app. Shame Naim aren’t good at app development.

A word of warning though if anyone else is having this problem, make sure that you buy a sufficiently new Ipad able to load the app. In my excitement I tried with a cheap refurbished one to start with and could not load it.

John

I got a reply from Alex Roberts from Naim who promised to do some comparative tests between iOS and Android with the software team. So the issue caught their attention… Watch this space :slight_smile: