Uniti Core not ripping

Not sure what’s wrong here . I put a cd in but it doesn’t rip. The eject button doesn’t work so I then have to use a paper clip to eject the cd. I can still access the CDs I’ve already ripped. Help !

Have you tried a full power off restart of the Core? Turn the power off completely at the wall socket or pull out the power plug, wait ten seconds or so and then plug it back in. It will restart and when it’s finished it should work again.



Will try that now, thanks David

It’s not worked . I updated the software to 2.5.1 last night - do you think that has anything to do with it ?

I recently had a cd with copyright protection it would not rip or eject. I had to turn on and off and it eventually reluctantly ejected it. A look on the web gave a clue that this particular blue Nile cd had been released with protection, subsequently otherbatches were not copy protected?

I’m only ripping standard CDs . It’s really odd that it’s just stopped working completely :pensive:

This was unmarked you would never know it was copy protected. But if all cd,s are not ripping, try turning off and on with a disconnection from the mains lead. If that does not work a call to your dealer or Naim.

I will do. Really disappointing , this was a replacement unit too as I had issues with the last one

It could be a network issue. I had a similar thing happen. My network had got itself into a muddle. We managed to sort it all out and after resetting all network devices and tablets, all was fine again, including the Core.

1 Like

Yes good point Richard. Turning everything off including any switch and the router would be a good suggestion. Then turn router back on let it reboot etc for a few minutes and then gradually turn each switch etc back on, leave for a while and then finally the Core last of all.

The firmware update won’t be the problem. It’s been out for ages and there have been no reported issues like this. But something else you could try if the network restart doesn’t work is to do a factory reset on your Core. You do that by taking the power off as I described before, then keeping the standby button on the front panel of the Core pressed in, put the power on again. Keep holding the standby button in until the light by the front panel USB flashes, then take your finger off the standby button. The Core will finish restarting in a few seconds. You can tell because all the lights stop flashing and you can see the Core in the app again. You will have to tell it where the Music Store is again but it should tell you that it has found a Music Store and ask you whether you want to set that as the Music Store again. This doesn’t involve reformatting the disc. Also resetting to factory settings doesn’t restore the old firmware. So you will still have the latest firmware.


1 Like

Good afternoon all,

Not wishing to detract from OP.

Is there an update for the Core and to transcode flac to wav?

No. The last update is a couple of months old and was bug fixes mainly. There is no news on any transcoding firmware.


Thank you David, and for all your help around these parts. You sure have been a savoiuor to me on me occasions although I’ve not always posted to say as much…so Thank you!

Back on topic…!

Since the OP can’t eject a CD by pressing the eject button, it doesn’t sound like a network issue to me at all.

But I do dimly recall an instance in beta testing way back where a Core wouldn’t eject CDs after a beta firmware upgrade and the advice then given by the Naim developers was a factory reset of the Core, which is done in the way I described in an earlier post. In that case it solved the problem.


It must be something to do with the update . The problem started immediately after that . I’ll do a factory reset this evening and report back. Thanks for the replies everyone , much appreciated .

That would be “High”, at a guess. Sanctuary erroneously included the same weapons-grade copyright protection on the initial pressing that was used on promo copies. At the time they mailed out replacement copies to anyone who emailed them requesting one. IIRC the copy-protected CDs can be identified by looking at the playing side, where it appears as though the entire disc has been used even though “High” is only ~40 minutes long.

Sadly the factory reset didn’t work nor did turning everything off and on again . Looks like it’s back to the dealer :sleepy:

I think the issue must be mechanical . After I manually eject the disc and try and reinsert it make a terrible noise like a tiny electric drill against the cd ! Very odd .

I hope it doesn’t take too long for a replacement .

Sorry to hear that I have a Core since launch…no problems so far🙈

1 Like