Uniti Core not showing albums following restore from backup

As the title, Core is only displaying 33 albums of nearly 1200 that were restored from backup.
Reason for restore was that I added some new albums this week and they refuse to appear in the app although I could navigate to them and play from PC. Tried various hard power down / off / reset app / uninstall and reinstall app / rebuild database etc no joy, all of the previous music appeared up to and including the additions the week before.
I had a similar problem before 3 yrs ago and I reviewed the advice from this thread

but nothing there has helped.
I have now redesignated music store and reformatted and then restored from my backup drive. This process took in excess of 12 hrs but the app reported a success with 1tb of a 4tb drive used.
However I now can only view 33 albums on app or via network from PC. These albums were ripped to core and appear in MQ folder. There were @ 1100 rips from cd and @ 200 High res albums

I must admit that I don’t know what is going on with your Core but instead of a restore from backup, you could try importing to the Core from the backup HDD. There is an option “Import Music” under “Manage Music” in the Core setup in the Naim app.

Also if it were me, I would be tempted to buy a new HDD or SSD for the Core and see whether that helps.

I did think of import as a possibility but wasnt sure if it would just dump all to the downloads folder, I’m not sure whether that would be another problem. I assume it would be best to “reconfigure new music store” formatting the drive and then import via front usb?

It may well put it all into the downloads folder, although the Core software is supposed to put rips it thinks have come from a Naim server into the Music/MQ.

The only disadvantage of the rips being in the downloads folder rather than Music/MQ is that you can’t edit the metadata with the Naim app, so you would need to use a metadata editor on a PC and point that at the downloads folder.

The Music Store is where the Core saves its own rips. You could put your backup on a USB HDD and plug that into one of the Core’s USB sockets, defining that as a Music Share. But that isn’t helping you solve your basic problem of rips going missing.

The backup is on a matching size USB HDD, but as u say that wouldn’t solve the problem… the last eight albums I’ve added have all been files downloaded from HDtracks/Bandcamp/Qobuz etc and all went to downloads folder. However the last 3 of them went missing. I transfer them over via the network, which has never been a problem. Once I had transferred these 3 they were viewable and playable over the network just not by the core/app

another query is why only 33 albums from 1200+. They also werent the first to be ripped, alphabetically they are last (xyz). I did have a thought that whilst restoring the Auto Standby kicked in, I assumed that the process would continue regardless but I changed to “never” anyway

what would be your estimate of how long to “import” a TB of files?

I have never known the auto standby to interrupt an ongoing operation. I have mine set to go into network sleep after 20 mins and pretty well everything that goes on in the background just carries on.

I’m not sure how long a 1TB import would take. But the worst it is likely to be is the same time it took to backup or restore that much. So do it overnight I suggest!

And I have no idea about the 33 albums. I still think it could be a hard disc problem. A 2TB SSD is only a couple of hundred pounds from Amazon…

Just looked through my backup drive to see about importing music. all folders appear to be empty apart from those 33 albums… which leads me to assume that I have restored thousands of empty folders, but why is the core reporting 1tb used? However I looked at the backup folder and There are 3 folders, Downloads, Music and Recycle bin. The latter has subfolders with all the files / music in their correct folders apart from the 33 albums. Have u got a recycle bin in your backup? I dont know how it got there or how the files got moved to the bin!

Naim are looking at another very odd case where waste bins have appeared in Core folders apparently. I don’t know where that has got to but I’m paging @Paul.B as he may be interested in this instance too, as it could be the same or a similar issue.

1 Like

David, as the Core owner you are referring to, I will be following this thread with interest.

My issue does not appear to be as serious as this could be but, is possibly related?

I have not ripped any CDs recently & am hoping all goes normally with the next disc I do. I have added a couple of downloads recently, including the album which caused my issue, with no problems.

I will look forward to seeing what Paul & team find out here.

So I’m busy copying all the music files from the recycle bin to Backup MQ folders, so far it appears to be populating correctly. my plan is once this is done to delete the recycle bin leaving the following folder structure [Metadata (454kb)] [String of numbers (1tb+) ] Details file (1kb)
Subfoldrs to string file are [Downloads] [Music] Details file (1kb)
Can anyone confirm this is the correct structure for a backup drive before I go forward and delete recycle bin?

BTW Canaryfan what album caused your issue? Wondering on the off chance if it’s any of these Arielle - 73, Jethro Tull - Rokflute, Ally Venable - Real gone,Fink - Fink’s Sunday night blues club, 2 were downloads from Bandcamp, 1 HDtracks and Arielle her own site

Hi,

I attach screen prints of the file structure of my back-up drive that I had previously sent to the Beta team so you can clearly see them. These are from a Windows 11 PC.

The disk that caused the problem I had was ‘Roots’, a double CD from Show of Hands. Briefly, my issue was that the names of both CD’s had been incorrectly shown on the original metadata from my original Core rip nearly 4 years ago. When I used the Naim app to see if the metadata had been updated to show the correct album name it updated the name, kept the same cover art but deleted all the track information, replacing it with a single track simply called ‘01’. This track would not play. I tried to re-rip the CD but only got the same result as after the attempted metadata up date.

I then deleted the album using the Naim app & downloaded it from a WAV rip I created on my PC. This worked perfectly, showing the correct name, cover art & track details.

I then backed-up the changes to be on the safe side & when checking the back-up disc on my PC, noticed the recycle folder which contained a full, working, version of the original album that I had deleted. My actual Core disc, when viewed on my PC with the ‘view hidden folders’ option enabled, does not show a recycle bin. This was when I reported the issue to Naim, under the Beta forum of which I am a member.

The Beta team have since purchased a copy of the same CD & reported similar issues to mine & are investigating further. They will no doubt report their findings in due course.

I am no Core expert, but if I were you, as the recycle bin appears to be doing no harm at present, I would not delete it until you have referred your issues to Naim support.

Finally, here are the screen prints of my back-up disc folder structure:-




For your information my Core has a 1TB SSD drive that is about two thirds full with about 500 CD rips & just over 100 download albums.

Interesting that a CD could cause those issues, Im sure I’ve seen something similar when ripping CD’s / files on a pc in the past where the pc copies rather than rips and the cd player then only “sees” 1 track.
I have moved all the files to their respective folders in the backup HDD and then unfortunately I deleted the recycle bin (before I read your post) but it doesb’t as yet appear to have caused an issue. I am now doing a restore from backup (12% currently) and I can review the files and play them throughthe network on my PC, currently only the Downloads folder is being populated but I can only see a small selection of them within the app in either Albums or Newest Music. There are the original 33 plus now another 9. Actual number of albums now in downloads folder is in the hundreds. Hopefully when restore finishes, I reckon @ 4am, I cna power down core and on restart it might repopulate albums in app.

Wishing you good luck & hoping all turns out well for you.

What really seemed to get the Naim people responsible for the Beta forum interested was the mention of the recycle bin, which they say they have never seen before in the Core or any back-ups. From my screen shots, it is obviously there & your experience, whilst slightly different from mine, backs up this & makes it interesting to see what Naim eventually have to say about it & if it is connected to the problems we both have had.

Update! Thankfully the restore from backup went without incident although it took 24 hrs. All files are back and playable with a few minor errors, missing album art on a few compilation downloads, I can live with that!
I added the new music which appeared to cause the original problem, without incident and then did a new backup which was 41 files. The only issue I have now is that the “manage music” “configure music stores” “view store” displays the Capacity as 4tb and available as 2.1tb, although the backup drive displays 4tb/3.1tb. Viewing over the network confirms that the Core drive has 0.9tb used. There do not appear to be any files/folders on the drive that would effect that discrepancy, no recycle bin or similar just the Downloads and Music folders, any ideas what could cause this? I’m a bit loathe to go messing around with it anymore and being as I’m not likely to acquire enough new music to fill that drive I’m not particularly worried, or should I be?

I suggest leave it alone and see what emerges from the Naim guys looking into these issues.

Very good/sensible advice.

thanx guys

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.