Uniti Core unable to view music

Bit of a long read I’m afraid, the text below was emailed to Naim support but they have a standing minimum of 4 days prior to answer, so I was hoping somebody on here could advise in the meantime…
I downloaded some new music to my Core but was unable to find / view it in the app. I can see the music from my PC in the downloads folder and I can play the music on my PC by accessing it through the downloads folder. I deleted and re downloaded the music with no change. I could see and access / play all other music on the store.

I looked through the forums / support pages for some help and tried the following (in order):

Turned on and off at power

Killed and restarted app

Reset app

Rebuild music database

Cleared image cache

This has now resulted in Albums and all other fields “No results”

There are some albums / tracks / playlists listed below with a circle and exclamation mark next to them but they are not accessible.

I also following further reading on this forum carried out a “Factory reset” and reset music store to internal drive. There was an option to “do not use this drive” but I couldn’t see the point of that so re-aligned it as internal. I also tried rebuilding music database with no apparent effect.
However there is still no change in state.

I can still see and access all the music on both downloads and Music / MQ folders via pc / network.

In app settings I can see music store (4TB) has 3.3TB free which to me appears about right for @ 1000 albums / cd’s.

I would appreciate any further ideas…

I expect we can sort this out for you!

The “don’t use this drive” option in setting your music store is just so you can change to another drive as music store and keep the existing store as a share, so you did the right thing assigning the existing internal drive to again be your music store.

When you put the downloads in the downloads folder, how did you arrange them? If you just stuck them all in the downloads folder one beside another, then there is your problem. What you should do is ensure that each album is in its own sub folder. The standard Naim arrangement is downloads/artist name/album name/music files and cover image. But it doesn’t have to be like that as long as all the files are in a different folder for each album. The cover art should be a jpg file called folder.jpg or cover.jpg. And it sits in the album folder alongside the music files which is one file per track on the album.



Hi David
All downloads are arranged as you suggest although there are multiples in some artist folders but each has it’s own album title folder and folder.jpg artwork.
Problem only occurred Monday, I also added new music last week without problem, but now cannot view any of it…


Ok. Good re folders! Multiples in each artist folder is perfectly fine by the way.

Did you try another power off restart of your Core? I found recently that I had to restart my Core twice for all the music to show up.

By power off restart, I don’t mean a factory reset. I mean put it into deep sleep by holding the power button in for 5 secs then let go and let it shut down. Then unplug the mains for a few seconds, count to ten for example. Then plug the mains in again and let it fully start up. Then hopefully if you look in the app, going right back to where you select the Core as the server, then select albums or whatever, it should all be there.


Tried that, no change, not sure what u mean “going right back to where you select the Core as the server” I checked in configure music store and the internal drive was still as is, I can view details, capacity etc
I still cannot see any albums/artists/genres etc at all I get “No results” in the app although I can “see” all via network…

If you have a Naim streamer then in the app you choose the server but if you have a Core playing into something that isn’t a Naim streamer then you go straight to the Core home page, so don’t have the option to select the server.

Not sure what to suggest now. Let me think about it and see whether anyone else has an idea.



Ok here’s an idea. This is counter-intuitive because you can see the files with your PC, but the Naim system uses a particular way to find files and if your router isn’t responding fully according to the specs, then the Core may show your PC but not the app.

So the suggestion is to restart your router. You should turn off the Core and swipe the app off, then restart the router and let it finish, then put the power back on your Core, then reselect the app.
Good luck!


The core is connected via ethernet from a powerline socket. I run music through a DAC to Amp. The app is on both an android mobile and a tablet and displays the same view / info.
I have turned off and restarted both but still no change to either the App or PC/Network view.
I’m tempted to re-rip a CD that I know is there to see if that shows up… or to do a full restore from backup, I’m not sure if that will add all to core or overwrite that already there, even tho it cant see it in the app.

I would still suggest restarting the router. You could certainly try ripping a CD. But I doubt that will tell you much. Of course if it shows up and nothing else does then that would be interesting.

If you are going down the route of reinstalling your music from a backup then it would be best to let the Core format the internal drive and start with that clear and import everything. Otherwise I’m not sure what might happen as it’s unclear why it’s necessary to do it.

Also did you restart the Powerline adapters?



Restarted powerline (1st) with core off restarted core same results, restarted main router , no change, restarted powerline and core again no change…
Ripped a cd which is already in the library, lo and behold it appears under albums/artists/genres etc
On viewing on network/pc there is only one copy of this in the library.
At least that tells me that it can work, it just can’t “find” all the other files.

Amazing. I wonder what happened to your music store then?

Well your plan of restoring from a backup probably is the best. You could try without formatting the internal disc first. There isn’t much to lose.

The only other thing I am now wondering is how full is your music store? I have heard that things get unpredictable if the store is more than about 95% full so if it were pretty full that might explain why it all went wrong when you added some downloads. Edit: No I see you already explained that you had lots of spare space…



I’ve seen that before but unfortunately it’s got 3.3 of 4tb left, about 1000 cd/album downloads.
Restore from backup does seem possible…

Interestingly I just tried a Rebuild Music Database and the CD I just ripped has vanished…

It has joined the ranks of the ghostly past rips.

I’m inclined to rethink that you should reformat the internal HDD and restore from your backup.

Would be interesting to try changing your internal disc from a store to a share and see if that restores the music. It’s reversible too whereas formatting isn’t.

So could this be an App problem, not seeing the database?
and how do I reformat drive? is it as simple as from configure music store, click on it and it will format?
How do I change from a store to share I tried share scanning and it didn’t find anything

If it’s an app problem then deleting and reinstalling the app will fix it, because there is no current issue with the Android app not seeing Core rips (I’m a beta tester so I see a lot of postings about what is being addressed currently).

If you undefine the internal disc as a store, then it should be available as a share. But I’ve never done it so I don’t quite know…

The reformatting should be suggested if you try to use a new drive as a store. But I’m not certain how you invoke that. Perhaps when it says do you want to use this previous store as a store, if you say no the drive should still be selectable as a store, but you now get the format option…

I deleted and reinstalled app, no change…
I could try undefining store and then restore from backup, even if the backup duplicates the current theres plenty of room, but from the previous experience of ripping the cd it overwrites

Powerline adapters can cause all sorts of problems. I would try turning all of them off and using regular Ethernet cables, at least temporarily. Then restart everything and see what happens.