Uniti core

I don’t think it does support upnp.

It does. Check here - Uniti Atom Support | Naim Audio. Search for upnp. Here is a screen shot.

I agree about the Uniti Atom supporting upnp. I was talking about the Bluesound Vault2.

1 Like

Apparently you did say yes because you have a music store as you found when you checked. So that’s ok. The downloads folder will be there but you won’t see it in the app. You can see it if you look for the Core on your network with a PC or Mac (or indeed a recent iPad). The Core presents music stored in the Music folder and the Downloads folder in a completely integrated way, so you aren’t aware of what is in each.

That’s fine. If you downloaded those CDs on line, as distinct from ripping the CDs in the Core, then you can just add the tracks you are interested in to the downloads folder. If you ripped the CDs in the Core, then copy the tracks you want from the Music folder to a new sub-folder in the Downloads folder and delete the original CD rips with the Naim app.

So your Atom can access the music on the Core OK? Obviously both need to be connected to your network. If your Bluesound Vault2 is connected to the network, then you can add it as a “music share” in the setup of the Core. The Core will scan the music on the Bluesound Vault2 and you will be able to access that both from the Core connected to your MX160 and also the Atom. All the music from the store and the share will be integrated in the Naim app.



Download was a wrong choice of word. I ripped those CDs as my follow up sentence said, “I just want to get the best songs out of them and then box the pile away.”

Yes, they worked flawlessly together but the app is buggy. It often hangs and cannot find Atom every now and then. Reboot and then it’s fine.

I just tried Share Scanning and it says No Drives Found. My Vault2 is connected to the same Network with ethernet. I am not sure for Core to detect Vault 2 as a drive, Vault has to be configured/ format differently.

But I must say, I thought Atom would be the one connecting to Vault 2 not the core. I thought Core and Vault 2 would be in a sibling relationship and won’t be accessing each others’ storage/ files. Then again, what do I know!

I believe the Vault 2 is not upnp capable. That is why you are not seeing it. You will have to use a digital connection between it and the Atom.

I looked into buying the Vault 2i, and did not buy it because it doesn’t have upnp capability.

I use the IOS app with multiple streamers and it’s not at all buggy. The Android app is less good on some poor or old Android implementations, but basically this sounds like a home network problem for you to sort out (and I know that isn’t what you want to hear).

Ok I don’t know the Vault2 at all. If it’s a network hard disc it should be discoverable by the Core. If it’s a network server then it will run upnp, so the Atom should see it as a server, but the Core won’t recognise that. So the Core won’t be able to help feed your Vault2 music to your McIntosh.

If this isn’t all what you hoped, then the lesson is clear: read the specs before buying next time. I hope it all gets sorted out but I’m not sure I can help.



1 Like

I agree. App is not that buggy . Very much functional - using it for last 4 years. Initially there were many issues.

I’m also using IOS app with the iPhone 12. And I should not have any network issue such as signal drop as my Netgear Velop mesh system covers the whole house with ease. I never had an issue with BluIOS app and I’ve used it for the last 4-5 years. Anyway, we don’t have to solve the app issue here but I’m sure you are aware the rating on the app is 2 star. Not sure if they are just from all the nay sayers.

Vault2 does not work with Naim due to formatting issue I think. Maybe it’s a Naim and NAD competition thing.

Anyways, thanks a lot for all the help. I may have follow up questions later.

I’m happy to try to help you more if I can.

I use the Naim app on an iPhone12 Pro here and it’s totally bulletproof all the time. And that’s working to three older streamers, a Nova, a Core and a series 1 muso Qb.

My network is just an ISP Superhub and a separate wireless access point covering another part of the house. It all just works.



1 Like

I think folder.jpg files may not exceed 1MB to be displayed by the apps/Core. A I was setting up my Core I had to alter a few of my thousands of folder.jpg’s of which 14MB was the heaviest :smiley:


I understand this thread as Q&A for several topics regarding the Core.

I’m new to the Core and setup is now complete with nearly 4.000 albums on a 2TB Samsung SSD (as advised by Naim), all tracks within the Downloads folder with structure genre/artist/albums 1-n in separate folders and then the numbered tracks per album in each folder. All the tracks were meticulously tagged and named outside the Core.

If I force the refreshing of the database with the app (iOS), then the database is established. It works. After this process is finished then deleting or adding an album via network from my Mac’s Finder the automatic refreshing of the database only works a ‘few’ times. After the 4th or 5th altering of the database the Core stopps recognizing any alterings. I have to refresh the whole database again!
What’s going on here?
This behaviour is constant also after resetting the Core or restarting it.


Hi Jens

If you are altering files that have been ripped from CD by the Core and you are using something other than the Naim app, then you probably are breaking the indexing and you are lucky to recover it by a new scan.

You must only use the Naim app for IOS or Android to alter metadata for the Core’s own rips. If on the other hand you are talking about files in the downloads folder, as I see you are on reading your post again, then it shouldn’t matter how often you edit something or add a further set of files, it should still be picked up by the Core in a couple of minutes. You shouldn’t have to rescan. Or in other words, I don’t know what’s going on here!

The only thing I can think of is that if you are getting close to the SSD being full, then things can get a little unpredictable. But you are probably not that close?



Hi David, thanx for the reply :slightly_smiling_face:

The SSD is half full and I’m talking about the Downloads folder only. Completely filled SSDs are a problem in every computer every time. At least they’re getting slow.

What I tried in the meantime was deleting and reinstalling the app on my iPad. The first screen I saw after opening it again were favourites of RADIO STATIONS! On the Core room! They’re coming from my previously used Uniti Qute I think. The Cute is no more present but it’s remains survive. And needles to say the Radio stations aren’t working :grinning:

The freshly installed app has to observed by me for a longer time. I need more time to check out whether the problem depends on how often I change the folders. I can imagine that doing it a lot of times again and again with a short amount of time in between is not good…

I will report my findings.

So long cheers,

My case could not be solved by Naim’s local distributor and was handed over to Naim’s headquarters customer support. Thank god they have this really amazing support team.

Hi again.
The cause of my problems with the Core is now clear: The SSD model. I use a Samsung 870 EVO 2TB SATA SSD. This SSD causes:

  • stops the Core’s automatic update of the database as the ‘Downloads’ folder is altered by file operations or external metadata editors
  • stops the ripping engine by faking ripping success but nothing is stored within the ‘Music’ folder
  • Favourites are not stored correctly, for individual tracks it’s impossible
  • Playlists are messed up randomly with any tracks of the database after a restart of the Core

This is a nightmare. Samsung’s SSDs are the market leader and the Core is not compatible with it at least with firmware and iOS app 5.21.

Now I use a 5 year old WD Purple HDD 2TB (for video surveillance purposes) and this works flawlessly also regarding the sound. Noise and vibrations caused by this HDD’s motor are extremely low.

I hope for a firmware update for the Core. Naim is informed and we should hope the best.

Well, good luck to all using a SSD drive with the Core.


1 Like

Thanks for the update

Well for what it’s worth, I have been using a Samsung 2TB 870 EVO in my Core for two or three weeks now, during which time I have added numerous CD rips and hi res downloads. Everything is working properly for me and I haven’t seen any of these problems.




Also running the Samsung 870 EVO (2TB) very successfully since last July. Zero problems. Firmware up to date on the Core, and I run latest app updates/most recent Android and iOS versions on all my devices. My SSD is about half full.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.