Uniti firmware downgrade

Good to hear. We ‘may’ be on to a winner. :joy:

For me it’s 36 hours without any problem since the downgrade/upgrade. I’d at lest give it a try for anyone still experiencing problems. It’s weird, offcourse, but for me it works for 2 days now.

Alas, this morning, after 3 days without problems, the atom woke up with a non-responsive display again and needed a hard reset. Firmware downgrade and then upgrade is not the solution …

Rats! And it was all looking so good.
Oh well, back to the drawing board.
Not tried mine yet, will post back with results.
If it happens to me then its down to 2.61 and no upgrade.

I’m all right Jack! Still working for me.

I’ll downgrade to 2.61. This is useless. Currently again writing an email to Naim …

There has to be a contributing factor common amongst all of you with this issue. I wonder if it’s a certain production batch or some thing in the network code.changed thats made it sensitive to certain network conditions. Mines never once done this on this version but I have had lockups on the odd occasion on previous ones for no reason, and they where often to do with the unit loosing network for a moment.

Epic fail!
Ok this morning, switched to standby for about 6 hours, now problems return. Argggghhhh!
Jack is NOT allright.
Back to 2.61.
Another email sent.

Maybe you could all start by posting the purchase date, assuming this says something about the production date.

I don’t have any of these issues and I purchased mine on 15 July 2018.

January 2018 for my first that got replaced by Naim for a new one last June due to a fault after the last firmware update. See a pattern here.

Mine is September 17

@Hifi-dog, did you go to 3.2?

Yep the day it was released. I’ve been working with my dealer and my nova is stable if we turn off the Wi-fi in my BT home hub6 and use another router( old belkin) linked to it for wifi. To prove this I went back to the bt router yesterday and this morning it was locked coming from standby using the remote

If it’s any consolation I have an Aries G2 and also have freezing issues. Others also suffer as evidenced on their forum. HQ can’t find the issue.

Luckily the freeze can be unfrozen by using the roon app to control it so as SQ is to my liking I put up with the glitches.


What I meant to say was did you downgrade and the upgrade to 3.2?
How long has it been running with the wifi mods you describe?

Ah ok . No I have not been sent the old file do on the orginal 3.2 it ran fine with the Wi-fi mods for four days and froze the very next day I reverted. I intent to run it with the two routers for a couple of weeks to be sure. I am running wired connection via switch to nova

1 Like

I have retrograded to 2.6 and all is now functioning normally again. I tried the 3.2.0 upgrade again and got the same blank screen problem. I have no retrograded again and am not going to upgrade until Naim sort out the problem.

@Hifi-dog. I’m trying to get my pea sized brain around this.
I’m finding it difficult to understand why, if you are using cable, would wifi have anything to do with this.
Can I ask a question…all based on our well tried and tested method of guesswork.
Have you, at any time, ever used your Nova on wifi?
If you have, maybe there’s something in the wifi config that occasionally polls the router to check connection even though you are now connected by cable.
If that’s the case, why is it still there after a firmware upgrade/reset.

I did use wifi for a short period of time (about 2 days) way before the 3.2 upgrade was out but reverted back to cable as soon as I could. At the time I didn’t notice any issues.

I suppose it won’t hurt to ask everyone who is having problems…
Have you ever, at any time, used wifi to connect your Uniti to the network. Either pre or post 3.2 upgrade?

We r struggling with this also as nova always been wired connected. Whether it’s the way the bt hub handles switching or something we don’t know but it was never an issue prior to 3.2 upgrade. I’ve sent a load of details to naim over the last 10 days which they have found useful so we will have to see . Urge everyone to report in detail to naim about the fault and network conditions.

I have suffered from this a few times since the upgrade but clearly not as badly as some. A minor irritant for me rather than what is clearly a major glitch for many. To answer the above questions: the Nova has never been used wirelessly, the router is a BT Homehub 6.