Uniti Nova update 3.7 locks up when mains power spikes

Hi, I recently updated my Uniti Nova to the latest firmware (3.7). Following this update my Nova now appears susceptible to main power spikes. When I turn off certain lights, usually ones with florescent tube starters or stop the motors on the electric window blinds (both of which could cause small mains power spikes) the Nova stops streaming music and the screen goes blank, only the 4 buttons on the right side of the unit remain lit.

The unit has to be shut down (via the remote) and powered on several times to restore playback.

This has only happened since the most recent firmware update - nothing else has been changed since the Nova was first installed 6 months ago and prior to this update the Nova worked perfectly OK. So not sure why a firmware update should have caused this to happen.

Hello Alan and welcome to the Forums.

Well this is an odd one!

First things first, I would suggest a full power cycle of your Nova - unplug from the mains, leave for about 30 minutes then reconnect.

Can I also check if you are using a Naim Power Line or Power line lite mains cable (which comes in box with Nova)? Also if you are using any other mains treatment devices.

I’m wondering here whether the IEC plug has moved and is now perhaps making a poor contact. I would follow Clare’s advice, but take care to ensure the IEC plug on the mains cable is properly and securely inserted and see if that cures the problem.

1 Like

Ho Claire

Power lead is the one that came with the Nova (european plug) no other main conditioning in place. Problem has only started in last couple of weeks and only change I can identify is that I applied the latest firmware update.

Problem is repeatable, and linked to specific electrical items being turned off - lighting that has a florescent starter and electric window blinds.

I haven’t tried the hard power down yet


OK thanks. It’s worthwhile re-making the connection on the IEC to Nova anyway when you do the full power down, mains lead out.

Unit has not been moved so mains plug is in exactly the same place that it has been for past 6 months

Richard means the IEC plug that connects to the unit. If it’s not firmly seated it can have odd consequences, and it’s best to rule out that the problems starting post-update isn’t just a random coincidence. I had a fuse blow once when I very slightly touched the cable - also turned out that the IEC plug wasn’t fully inserted and it sparked when I touched the cable

1 Like

I have powered off the Nova, removed the power plug, waited 30 minutes then plugged everything back in and restarted the Nova, and so far for the past 2 days everything has been stable and no crashes.

What I still do not understand is why after 6 months operation with the Nova not being touched or moved (I always use the remote or app to control the system) it should suddenly become susceptible to power glitches - the internal power supply should filter these out. The only change to normal operation has been the recent 3.7 firmware update.

Firstly, I’m glad the power cycle appears to have sorted your issue.

Digital systems are complex creatures; without a full system diagnostic (which the Naim Support team can perform if needed), it’s impossible to say for certain what caused it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.