Uniti Star CD not working

The CD player in my Star has stopped working, won’t play or rip to music store. If I check on the app it shows the CD as ‘loading’. This is the case even when the system is restarted after being unplugged for several minutes. All CD functions remain unusable via the app or remote control.

The only way to eject the CD is by using a paper clip to manually eject it.

I have factory reset the Star (had to re-pair the remote and router access, so assume this means the reset was done correctly), am on the current firmware and have tried various CDs that worked previously when ripped to the music store.

This is the second time the CD player has stopped working, in 2019 it went back to Naim to be repaired. Since it was returned I have ripped a dozen CDs at most, in total 700 albums and never been used as a CD player, so minimal use.

Any advice on what the next step is would be appreciated.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.