Uniti Star Servers Local music (USB SSD) shows 'No results'

I have a samsung SSD connected via the rear USB port on my Uniti star. I have around 200GB of CDs ripped onto the drive. Today when I tried to access it via Servers then Local the message ‘no results’ appears. When I check on the app on my iPhone ‘manage music stores’ the SSD appears but I am unable to access or play the music. The files are visible on my mac but don’t seem to be able to be read by the Uniti Star any more. I have updated the firmware, unplugged the system and unplugged and plugged the SSD in a couple of times without any luck. I’d be grateful for any advice about how to rectify this.

It might be a format issue with the drive. If you were starting from scratch the Star would format the drive itself to NTFS. If you have a different format, this could be the issue?

My Star is constantly doing this with my local music, I am using a 32g usb stick. Been told that it is a known problem! I am at the end of my tether with my Star.

The File format is HFS+ I think this is the file format recommend if using a Mac.

I am a Mac user, but I’ve always found it’s best to format USB sticks to MS-DOS (FAT-32) for universal compatibility (not even Ex-FAT). This has worked on nDAC when nothing else would, for example.

You are right - unfortunately - HFS+ is one of the formats Naim say is supported by the Star, so that does not explain your problem.
If you open the USB input instead of the Server input, can you see the music files there?

I had a similar problem with an HDD. I got around it by formating the HDD and then copying the ripped CDs to the drive.

I’ve tried opening the USB input instead of the Server input but it still isn’t able to read the drive. I’ve tried plugging the drive into the front of the unit as well but no luck. I am wondering if it might be worth formatting another SSD on the system and then copying all the music files over from my existing drive to the new drive - does anyone know if this might work? As it took many hours to rip hundreds of CD’s onto the drive I’m really keen not to have to go through that process again.

Looks like I posted at the same time as the last reply - Many thanks I will try formatting the drive and copying all the files across. Is the HFS+ format as stable as other options?

An odd thing has happened. I was in the process of copying all the files over to another HDD in order to format the original drive and then copy the files back over. After making a copy of the files I plugged the HDD back in the Star ready to format it - I checked again and it is now reading the drive again and the thumbnails of the CD art are rebuilding on the Naim app on my phone - currently at 283 albums and counting. Seems to be working again (as is Tidal which has been down for a day or two). Fingers crossed.