Unitiserv not loading the disc

I have a unitserv and started ripping discs after not using the player for a few years. I loaded 120 discs without an issue. Now the discs aren’t physically loading into the player. The disc starts to load, it gets into the machine about 98%, a grinding noise happens and gets spit out. Will I need a new loading mechanism? Is it an easy fix? Thoughts? thanks.

Have you tried a power off restart of your US? You must shut it down the correct way, which is to touch the front panel logo for a few seconds until it starts to flash, wait until it goes off (takes about one minute), then turn off the power switch on the back of the US and then turn the power switch to on again. The US will restart (takes a couple of minutes). Once the logo is steadily on, the US should be back on line and normal service will hopefully have been resumed.

It is worth putting the latest firmware on the US which is 1.7c. It greatly speeds up the metadata lookup process. You have to ring Naim support to get a disc sent to you, but you will need to check what firmware you have now as they have to be done sequentially. All the earlier firmwares are available for download from Naim’s website.



Hi David, thanks for the reply. I have tried repeatedly to start the unit back up and load a disc. Unfortunately, the disc catches and doesn’t load. It goes into the slot about 95% or so, than the machine just makes a load whirring noise. The disc spits out and the machine makes a grinding noise. The loading mechanism must be shot? Hopefully there is an easy/inexpensive fix.

You should talk to your dealer. If it has to go back to Naim then they have a fixed price for servicing a Unitiserve to bring it up to new standard. It’s not cheap at all unfortunately. But maybe your dealer can see whether something simple has happened.



I have a SSD Unitiserve and had nothing but problems with it. Trusted it completely at first and kept feeding it discs until I realised I had over 50 “unknown” disks ripped. That meant I could no longer insert a disc and walk away, I had to check every time to make sure metadata was added; quite often it wasn’t. There were discs that didn’t load, discs that didn’t eject, discs that ejected onto the floor, thermal shutdowns (mine often ran hot). It was bought as a high quality, simple, efficient ripping solution but it needed so much babysitting it was anything but simple or efficient and I gave up ripping CDs on it. As more products came to market discussions about the quality of US rips vs others arose and I decided (for the avoidance of doubt rather than a verified quality issue) to eventually re-rip everything, probably with a Melco.

It doesn’t help with your problem unfortunately but it might provide food for thought before you spend your hard earned to fix it.

Your Unitiserve clearly had a fault, and/or possibly a network problem affecting its comms with the NAS. If it’s that bad, surely you’ve been back to your dealer to get it sorted? Mine has worked more or less flawlessly for nearly 8 years. It only ever failed to rip about 3 discs, and very rarely failed to find metadata.

Regular communication with the retailer and distributor never managed to sort it and it was generally acknowledged it was just not a very good piece of kit. I have seen lots of comments about US problems and would not put any money into fixing one. I do appreciate there are probably more that don’t have problems than do (you for example) but I also realise I am not alone in experiencing these issues.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.