unitiserve 2tb back up to a q nap n.a.s.

Hi, i have a unitiserve 2tb and am currently ripping my cd collection, i would like to back up to my q nap n.a.s., they are both on the same network, when i try to set up a new share/store through the naim app i get stuck at the part which asks for “share path” , can anyone help? also what are the functions of the u.s.b. sockets on the rear of the uniti share ? everything ive plugged in is not recognised, many thanks

Hi, here’s a guide from Naim that explains how to set up a QNAP NAS for use with a Unitiserve:

It’s rather old, so I don’t know how relevant it will be to your NAS, but it might help, along with the Unitiserve manual.
Some of the Unitiserve configuration is best done via the browser interface, accessed by putting its IP address into any web browser.

1 Like

Regarding the “share path” that means the IP address of the NAS drive on the same network as your Unitiserve.
In the case of my own backup NAS drive, it’s entered in this manner: \\\NaimBackup
The number will depend on your own network and router.
I found the IP address using a free app called “Fing” which scans the network your phone is connected to and shows each device and its IP address.
It’s important that the folder you create on the NAS drive (in my case I named it NaimBackup) MUST be empty. Do not add any subfolders or files. The Unitiserve will create these automatically.

hi , thanks for help, i have now managed to set the qnap up for backup as described in your link page , however it is not backing up, (see next post ) many thanks.

hi thanks for your help, i have now got the qnap as a backup but nothing seems to be happening, i don’t know if i can upload photos on this site ? to show what is going on /or not!! many thanks.

It’s easy to upload photos. You can drag and drop them or you can go to the icon of a mountain in a photo bottom right of the edit box and then take one off your phone. You don’t need to host them somewhere first.


thanks will upload some shortly, carl.

Have you followed the instructions in the Unitiserve manual for setting up the backup to a NAS? It should start the initial backup when you’ve done that.

From memory, you have to set it up as a backup - not only add it to the system as a share, but also change it to a backup.
Additionally(!!) you need to schedule when it carries out the backups.
I love the way it does things, as once I’ve ripped my CD’s, it automatically does back-ups, in my case, to multiple NAS drives, including one remotely in my garage. Hopefully I’m OK in the event of some massive failure…
Once it has successfully carried out it’s first back-up, the folders and files will appear on the drive.

i have to admit this is defeating me ! i have never come across what should be a simple task turning into a nightmare, i enclose some pictures , whether they are any help or not ? thanks to all for your suggestions, carl.

Looks like you are using N-Serve on a Mac. Have you been using this for all the Unitiserve setup so far? If so, I would suggest you use the browser interface instead, accessed by putting the US IP address into Safari or any browser. Enable the backup from there.

You might try disabling the Recycle folder within NaimBackup on your NAS as I believe the folder “NaimBackup” must be empty.
Also, control.ini shouldn’t be there, if it works the same as my HDX.

once again thanks for all suggestions, i did manage to find the app through the i.p.address on my iMac, (yes i had previously been using the n serve app ) very slow and clunky too. Im afraid to say i am no further forward, problems too numerous to go into , briefly…unable to connect…cannot convert to a backup…share already in use etc etc, i emptied the share folder as suggested but still no good, i have spent since ten o clock this morning on it now 2.30 pm. SO i have decided i will get a uniti core, mainly due to larger storage options and also i can back up to a plugged in h.d. via u.s.b. i am pretty sure you can’t on the uniti serve??? as i previously mentioned whatever i plugged in to the rear of the the unitiserve was not recognised, i know if i spent many frustrating hours on the unitiserve i could probably get it connected but can’t face it ! i appreciate your help from you all, cheers carl.

Doncarlos, wish I could be more help, but I do know that setting up back up nas to the unitiserve is complI acted and has defeated many on this forum including me. A few years ago the problem was solved by NAIM support (Phil Harris, incredibly helpful but I think no longer with NAIM) logging in remotely to do the set up. Not sure if they still offer this, but perhaps worth asking…

Good luck Paul

Hi paul, thanks for post, you know that well used saying about rocket science!! i don’t really want to splash out on a uniti core just because of this problem , i can usually work through these things, in this case im defeated, and it just got worse, lost my downloads folder from the uniti serve, i really need someone to remote into the system, would you suggest i contact naim to see if they still offer this type of service? it would save me a lot of money/ frustration , many thanks carl.

Definitely worth trying, but I don’t know how likely it is that they will help.

I think most important is the Workgroup Name „Naim“.
But when Backup is running… what about restore?
There is no sql Database Backup, so how to get data back into the System?

I managed to so this with no real IT skills, so don’t give up! Once set up, it’s all automated, and you don’t have to do anything.
It’s worth asking Naim support if they have any suggestions, or @Stevesky might be able to help.

I’ve restored from backup twice, it was a few years ago, and I can’t remember exactly how I did it, but I do remember that it was very straightforward.
The other advantage of having the backup on a NAS is that you can run a UPnP server on that NAS, and still have full access to your music, without having to wait for a repair or replacement.

There is no hint how to restore in the Server Software. And as long as „Music“ folder is Write protected you can‘t copy anything there.
I am really not sure how restore should work.