UnitiServe not in Finder

My UnitiServe was repair by a Naim dealer, and since getting it back, it isn’t visible in Finder on my Mac

It is however connected to the network, as I can log into it’s IP address from my Mac, which I had to do to correct the dates, it backs up to my NAS and I can access it via N-Serve to edit artwork etc. New Rips are also visible there straightaway

Any obvious reason why I can’t see it in Finder?


It’s probably because the version of MacOS you are using doesn’t support SMB1, which is what you need to be able to talk to the Unitiserve downloads folder. If you google how to turn on SMB1 in MacOS there is lots of advice. It does depend on exactly which OS you are using I think. Catalina seems the main problem.



Thanks David - Yes I am on Catalnia and the latest version of Catalina too - I will google as you suggested


Is this the issue you discuss? Just nosing around the web

It is the issue, but the solution is different because whereas you can tell a NAS to use SMB3, you can’t tell a Unitiserve to do that as Windows XP Embedded which the US uses only supports SMB1. Microsoft never issued an update to Windows XP Embedded to allow you to support SMB 3 (or 2 come to that). And of course XP Embedded is well out of support by Microsoft now.

So the Mac has to be told to use SMB1 for this connection and it isn’t wholly straightforward.



I’m on the latest version of Catalina and can see my US in the Finder. No changes made since any upgrade.

Update - I am. running Cataline on my MacBook and the US is visible in Finder on there and I can access the files on it! So it seems like it is an issue on my iMac - Maybe the time for the old IT Helpdesk solution - Turn off and on again…

I have exactly the same problem. See the end of the threads below.

In summary, I have two different Macs running different versions of OSX ( forget which version but both pre-Catalina) neither can now see the Unitiserve in Finder, and also fail at the authentication stage if you try to use Go>Connect to Server. All was fine about 9-12 months ago, but now for some reason something is broken.

Trying to fix it results in the usual IT run-around. NAIM Helpdesk couldn’t help and referred me to Apple. I then spent 2 hours with Apple Helpdesk who couldn’t fix it and referred me to NAIM.

I am not aware of any setting in a Mac OSX to specifically enable SMB1. The Helpdesk said that it is enabled provided you have enabled Windows and SMB sharing in System Preferences>Sharing, which I have.

I have given up trying to fix it. If you are trying to access the Downloads folder in order to add new music, a work-around is to put the new music on a USB stick instead and plug it into the back of the Unitiserve.

See threads below.

Good luck, and if you have more success than I have had, please report your findings !



1 Like

I too have this problem. I found that restarting my MacBook did sometimes allow the UnitiServe to be seen in Finder, but not always. When I did see it I got into Downloads > MQ and managed to transfer a recent downloaded album. The problem is that this album does not appear in the UnitiServe, nor the QNAP NAS that the UnitiServe is supposed to update each night. So I am unable to play any new downloads!

Are we now saying that it is impossible to install new music downloads MQ onto the UnitiServe and actually play them?

1 Like

Something has broken somewhere. I just bought a Uniticore to replace the aging but faithful UServe but the Core can’t see the Unitiserve either ! Just posted a thread about this …see below.

Seems to me like a sharing/permissions issue, or a SMB1 issue.

My Mac still can’t see the UServe either, (although it could about 9-10 months ago).

Please report any updates / new info on this thread and I’ll do the same.



1 Like

Paul, the thing that I find strange is my MacBook can see the US, but my iMac can’t. The iMac is hardwired to the network and the MacBook is WiFi.

Can you try a very limited network, omitting the router and just connecting the US, UC and a Mac/PC to a network switch? You won’t have internet, but if visible you’ll be able to transfer files?


Nigel, even if you can’t see the UServe in Finder, a work-around to add new music to the Serve is simply to put it on a USB stick and plug it in - the UServe has 4 USB ports, enough for quite a lot of music. Just a bit clumsy, and every time you want to add more music to the same USB stick you would have to either disable it in the n-Serve app, or power down the UServe.

Apologies if this has been mentioned but if you go to System Preferences/Sharing/File Sharing is the latter on (tick in box)?

I have a newish MacBook and an oldish iMac, both wifi connected, both running latest software and can see my US on both.

Thanks for the suggestion Richard, in my case yes I have the sharing enable and also the option for Windows SMB sharing. I also have 2 Macs, one recent and one old, one wired and the other WiFi, neither can see it.

An important question - what firmware version is your Unitiserve ?

Thanks, Paul![iMac file sharing|638x500]


1.7c RC1 but I’ve always been able to see the US, irrespective of version.

What happens when you go to Finder/Connect to Server and enter your smb://nssrvaf host name?

What happens when you put your host name into Safari?

1 Like

@Richard -THANK YOU! I ticked file sharing and miraculously my US appeared in Finder!!!

So - To summarise:

  • I have the latest version of Mac OS - Catalina, installed on both iMac and MacBook

  • File sharing is ticked on both

  • Unitiserve Firmware is 1.7b

Glad it worked.

Hi Richard, thanks, Im on firmware 1.7RC1 too, I was trying to establish whether this update may have upset something, but apparently not for others at least.

If use Go>Connect to Server it tries to connect but then fails at the authentication stage, whether trying connect as guest or registered user ;

Interestingly, but not sure if this is relevant or not, if I use the Userve web interface in Safari I can see that the Serve has enabled the Core folders as network shares ;

Most odd, this did all work about 9 moths ago on both Macs but not now. I might upgrade the OS on of them to Catalina to see if that helps, but I don’t see how it would help the Core to see the Serve.

Any help gratefully received !

You should certainly be connecting as Guest, with no password.

Have you tried entering the US host name? Found in n-Serve/Maintenance/System Status. That’s how I connect.

What happens when you put the host name into Safari?

There is no user login for Unitiserve users, you just need to go in as a guest user.
You appear to have 2 Cores seen by the Unitiserve? The one that shows green light status on the Music and Downloads folders appears to gave a third, unnamed folder, which seems odd.