UnitiServe Prematurely Ending Tracks - An Age Thing?

I am having a problem with hi res music streams from my UnitServe to ND555 cutting off before a track ends. The track starts OK, gets quite a way through the track and then cuts off, going to the next track, which in turn cuts off before the end.

This problem does not exist with either hi res streams from my QNAP NAS (using both the proprietary QNAP UPnP or Asset) or Qobuz streams, only UnitiServe hi res streams (e.g. 96kHz and 192 kHz, 24 bit). All CD rips (16 bit) are fine with the US, and all tracks play to the end.

I have tried rebooting the UnitiServe, ND555, switches, NAS and router a couple of times, but the problem persists.

I have reported this to Naim Customer Services but wondered if any on here have experienced the same issue and can offer a fix.

Nigel, I’ve moved this topic to Streaming Audio, as is more appropriate. I’m afraid I can’t answer your question though, but hopefully Naim tech support will have an idea…

Yes, quite right Richard, it should be here in the Streaming Audio room.


Have you changed any settings like upscaling to 24 bit or upscaling to 24 bit WAV?

Oops just checked that and it would only affect things if you upped the sample rate at the same time. A quote from the Minimserver forum:

“Transcoding to 24-bit 384k WAV causes the stream to reach a size of 2 GB after 15 minutes and 32 seconds. The maximum size of a WAV file is 4 GB but some players don’t handle this correctly and are limited to 2 GB.”

Not knowingly.

How can I check for this?

I doubt that is your problem if you haven’t changed any settings but it can be changed in Asset as well as Minimserver - Transcoding from Flac to 24bit WAV can be done Ok and some report a sound improvement but changing sample rate can give the issue I added to my post above.

I should add that I tried this slightly daft experiment and long tracks were truncated because of the sample rate creating too large a file size.

I don’t think the US supports up scaling…,



Thanks Chris.

Asset and QNAP UPnP on the QNQP NAS don’t have a problem playing to the end of hi res tracks, it is the UnitiServe UPnP that is having the problem.

Then I’m sorry for almost leading you up the wrong path :slight_smile:

1 Like

Hi Nigel
Are the offending files saved in FLAC or WAV? Are you transcoding on the fly, and if so, what setting are you using for this? Maybe worth having a play with the different options, as if nothing else, it might help to narrow things down a bit.
Does the issue disappear if you set the US to convert to 16/44.1 WAV on the fly, or to 24/96 max? Or if you store as FLAC, does setting to Native help?

If nothing else, this might tell you if the larger file sizes are the cause of the issue when the server actually serves the files.

@NigelB you need faith (think was you that told that) to own a UST2. :grin:

I am a believer!

Praise the Lawd, and deliver my UnitiServe from the clutches of evil!

The Good Lord (Naim Support) has sent me his blessing (a support Ticket Number).


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.